Filter Condition Bug

  • 1
  • Problem
  • Updated 2 years ago
  • Acknowledged
  • (Edited)
I noticed that when saving a multi select condition with the "Remember last-selected filter value" option set to false, it makes the conditions disappear. I think this affects the event subscription to the condition event as well.

With "Remember last-selected filter value" set to true the condition is there



With "Remember last-selected filter value" set to false, the condition is gone


Here's the sample xml page

<skuidpage unsavedchangeswarning="yes" personalizationmode="server" showsidebar="true" useviewportmeta="true" showheader="true">    <models>
        <model id="Opps" limit="20" query="true" createrowifnonefound="false" datasource="salesforce" type="" sobject="Opportunity">
            <fields>
                <field id="Name"/>
                <field id="StageName"/>
            </fields>
            <conditions/>
            <actions/>
        </model>
    </models>
    <components>
        <filterset model="Opps" searchmethod="server" searchbox="true" uniqueid="sk-2eRq7_-109">
            <filters>
                <filter type="multiselect" filteroffoptionlabel="cookies on" createfilteroffoption="true" affectcookies="true" autocompthreshold="25" conditionsource="auto" labelmode="auto" conditionfield="StageName" conditionoperator="in"/>
                <filter type="multiselect" filteroffoptionlabel="cookies off" createfilteroffoption="true" affectcookies="false" autocompthreshold="25" conditionsource="auto" labelmode="auto" conditionfield="StageName" conditionoperator="in"/>
            </filters>
        </filterset>
        <skootable showconditions="true" showsavecancel="false" showerrorsinline="true" searchmethod="server" searchbox="true" showexportbuttons="false" pagesize="10" createrecords="false" model="Opps" buttonposition="" mode="readonly" allowcolumnreordering="true" uniqueid="sk-2eKRK4-113">
            <fields>
                <field id="Name" hideable="true" uniqueid="fi-2eKVU_-134"/>
                <field id="StageName" hideable="true" uniqueid="fi-2eKVV0-135"/>
            </fields>
            <rowactions/>
            <massactions usefirstitemasdefault="true"/>
            <views>
                <view type="standard"/>
            </views>
        </skootable>
    </components>
    <resources>
        <labels/>
        <javascript/>
        <css/>
    </resources>
    <styles>
        <styleitem type="background" bgtype="none"/>
    </styles>
</skuidpage>
Photo of Shmuel Kamensky

Shmuel Kamensky, Champion

  • 4,328 Points 4k badge 2x thumb

Posted 2 years ago

  • 1
Photo of Mark DeSimone

Mark DeSimone, Official Rep

  • 11,050 Points 10k badge 2x thumb
Hi Shmuel,

Thank you for bringing this up. I've been looking at your example page, and I see that when you save a filter with the "Remember last-selected filter value" option set to false, there is no auto-created condition listed in the model, whereas if I have that box set to true, I do see the dark-grey autofilter-created condition. 

Despite that, the filters individually both seem to perform as expected on the example page, except when they're both on the same page. In other words, even though that auto-filter is not showing in the model's conditions, the filter seems to function as expected - is this your experience as well? I have not tested anything regarding event subscriptions. 

-Mark
Photo of Shmuel Kamensky

Shmuel Kamensky, Champion

  • 4,328 Points 4k badge 2x thumb
You're right! It does not affect event subscriptions. It seems to be purely visual.

I thought it might because I am having issues with events on conditions on an active page, and it seems like a bug to me, but unfortunately I can't reproduce the issue on a standalone page and cannot share the page here.
Photo of Mark DeSimone

Mark DeSimone, Official Rep

  • 11,050 Points 10k badge 2x thumb
I'm glad this seems to have narrowed down the list of possible causes for your events issues. I will be sure to bring this visual inconsistency up to our dev team's attention.