File Upload Problem in Force.com Site

  • 1
  • Problem
  • Updated 3 years ago
  • Solved
I have a Skuid page with a File Upload that attaches the image to a custom object. It works great when I am viewing my page in Salesforce.

When I view the page via a Force.com Site, the upload button sort of works but not totally. It does upload the file to the object, but the button does not update to show the newly uploaded file.

See video.

I have included the Visualforce Page UploadImage in the site as instructed.

Any ideas?

Tony

Photo of Tony Sirna

Tony Sirna

  • 976 Points 500 badge 2x thumb

Posted 3 years ago

  • 1
Photo of Tony Sirna

Tony Sirna

  • 976 Points 500 badge 2x thumb
Really hoping to find a fix to this bug soon as I need to roll out this interface ASAP.

Any help from Skuid tech support on this bug?

Thanks,
Tony
Photo of Ben Hubbard

Ben Hubbard, Employee

  • 12,490 Points 10k badge 2x thumb
Hi Tony, what version of Skuid are you running? I think we have a fix for this.
Photo of Ben Hubbard

Ben Hubbard, Employee

  • 12,490 Points 10k badge 2x thumb
If you're already running a version of Skuid like 7.24, I think you'll need to re-copy your local version of Upload.page to duplicate the latest version that Skuid provides.
Photo of Tony Sirna

Tony Sirna

  • 976 Points 500 badge 2x thumb
It works!

I was on Skuid 7.19. I upgraded to the latest (7.27) and copied the new Skuid version of the visualforce page UploadImage onto my local copy.

Thanks for the tip!