file upload not working

  • 2
  • Problem
  • Updated 3 years ago
  • Solved
I know this question has been previously posted, but none of the solutions are working for me. I have a Wizard component that contains the opportunity object and a custom object that is a child of opportunity. The file upload component does not work. It doesn't work when pointed to either object or when I tried to create a separate page just for the upload function. It does not work in preview mode or production.  I have followed the tutorials and troubleshooting suggestions with no luck. I am using the most current version of SKUID. 

Thanks!
Photo of Justin Kruse

Justin Kruse

  • 314 Points 250 badge 2x thumb
  • Stymied

Posted 3 years ago

  • 2
Photo of Justin Kruse

Justin Kruse

  • 314 Points 250 badge 2x thumb
To add more detail...the upload component opens my file explorer and allows me to select a file...then it just thinks forever, and never actually uploads the file. I have tried files of various formats (word, PDF, etc) and various sizes with no luck. 
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
Here is a guess. 

Unitil the parent record is saved,  the file component does not have a record to save its data to.  In your wizard,  make sure the record is saved as you move from step 1 to step 2.   Then you can use the file component to upload attachments that relate to the saved record. 

There is one more key detail.  In the wizard component there is a property titled:  "Defer Rendering of Step Contents"   This needs to be selected so that the file editor does not try to render in the context of the unsaved record. 

 

I think that should solve your problem. 
Photo of Justin Kruse

Justin Kruse

  • 314 Points 250 badge 2x thumb
You are my new hero...I knew about the save file issue, but it turns out the magic trick is clicking "defer rendering" 

Thanks!