Field value won't clear / delete

  • 2
  • Problem
  • Updated 3 years ago
  • Solved
Several fields won't clear their values when I delete the values. They are also not triggering the save/cancel buttons that are set to render when the model has unsaved changes. 

These fields are set to render if a picklist field has certain values, but even when I disable that rendering they still are acting like this. 

I've never seen anything like this before, any ideas? I'm going to just delete the fields from the model and add back again and see if that helps. I had a similar issue last week with fields not respecting new dependency criteria on the skuid layout until I deleted them from the model and added them back again, so maybe that will help. 

Photo of Jack Sanford

Jack Sanford, Champion

  • 8,322 Points 5k badge 2x thumb

Posted 3 years ago

  • 2
Photo of Jack Sanford

Jack Sanford, Champion

  • 8,322 Points 5k badge 2x thumb
I have two field editors for the same model on the same tab, could this be causing the problem? It hasn't caused any problems in the past, I recently updated to the latest Banzai... Also it lets me input data just fine. 
Photo of Jack Sanford

Jack Sanford, Champion

  • 8,322 Points 5k badge 2x thumb
Ok, so here's what I figured out - all these fields I was working with are Percent fields that aren't clearing, and Skuid somehow does not want them to have a blank value. BUT, if I put in a 0 (zero) then it will accept that as a change, render my Save/Cancel buttons and save with a value of 00.0000%. That's not really great because we have other rules elsewhere about rendering if the field is blank/not blank, but at least we can edit it. 
Photo of Pablo Martinez

Pablo Martinez

  • 2,468 Points 2k badge 2x thumb
totally agree, I have also rules and validations depending if is blank or not (0 is a possible value, blank no) 
Photo of Bill McCullough

Bill McCullough, Champion

  • 12,436 Points 10k badge 2x thumb
Jack...I was helping another community member and saw the same thing with number fields.  You cannot leave them blank.  I am not sure if this is intended or if this is a bug.

Here is the link to the issue we saw:

https://community.skuidify.com/skuid/topics/black-fields-wont-allow-model-to-save
Photo of Irvin Waldman

Irvin Waldman, Champion

  • 9,006 Points 5k badge 2x thumb
I have the same issue and had to write JS to workaround for now.

@Skuid team, do you have an ETA for this fix?  I need to set proper expectations with the customer as to whether I roll out my interim solution or ask them to wait for the proper fix.  Please advise.  

Thanks!
Photo of Zach McElrath

Zach McElrath, Employee

  • 49,056 Points 20k badge 2x thumb
This has been addressed in Banzai Update 6 - Patch 1 (7.27.1), now available from Skuid releases page.
Photo of Irvin Waldman

Irvin Waldman, Champion

  • 9,006 Points 5k badge 2x thumb
Confirmed, thanks!