Field Editor Section Not Displayed when show header is no but last collapsible was collapsed

  • 1
  • Problem
  • Updated 3 years ago
  • Acknowledged
When a field editor section is marked to not show a section header, if the "collapsible?" property was "yes - initially collapsed" prior to turning off the header, the field editor section does not render at all.

Steps to Reproduce:
1) Create new detail page for account
2) Set the "Basics" section Collapsible property to "Yes - initially collapsed"
3) Set the Show Section Header to false
4) Save page
5) Preview page

Expected Behavior
Basics should show without a section header

Actual Behavior
Basics doesn't show at all

Sample Page XML
<skuidpage unsavedchangeswarning="yes" personalizationmode="server" showsidebar="true" showheader="true" tabtooverride="Account">   <models>
      <model id="Account" limit="1" query="true" createrowifnonefound="false" sobject="Account">
         <fields>
            <field id="Name"/>
            <field id="CreatedDate"/>
         </fields>
         <conditions>
            <condition type="param" enclosevalueinquotes="true" operator="=" field="Id" value="id"/>
         </conditions>
         <actions/>
      </model>
   </models>
   <components>
      <pagetitle model="Account" uniqueid="sk-NIaV3-70">
         <maintitle>
            <template>{{Name}}</template>
         </maintitle>
         <subtitle>
            <template>{{Model.label}}</template>
         </subtitle>
         <actions>
            <action type="savecancel" window="self"/>
         </actions>
      </pagetitle>
      <basicfieldeditor showsavecancel="false" showheader="true" model="Account" mode="read" uniqueid="sk-NIaV3-71">
         <columns>
            <column width="100%">
               <sections>
                  <section title="Basics" collapsible="collapsed" showheader="false">
                     <fields>
                        <field id="Name"/>
                     </fields>
                  </section>
               </sections>
            </column>
         </columns>
      </basicfieldeditor>
   </components>
   <resources>
      <labels/>
      <css/>
      <javascript/>
   </resources>
   <styles>
      <styleitem type="background" bgtype="none"/>
   </styles>
</skuidpage>
Photo of Barry Schnell

Barry Schnell, Champion

  • 18,076 Points 10k badge 2x thumb

Posted 3 years ago

  • 1
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
Yes.  I saw this happen yesterday too.  You have to go back in the builder and turn the header back on,  turn off the collapsable, and then turn the header back off. 

Annoying.. 
Photo of Barry Schnell

Barry Schnell, Champion

  • 18,076 Points 10k badge 2x thumb
Yeah, all of a sudden my field editor stopped displaying, took a while to figure out why :(
Photo of Tony Thomas

Tony Thomas, Employee

  • 80 Points 75 badge 2x thumb
This issue has been addressed in Rockaway Update 1 which is available now at https://www.skuid.com/skuidreleases
Photo of Barry Schnell

Barry Schnell, Champion

  • 18,076 Points 10k badge 2x thumb
Tested and confirmed with Skuid 8.8. Thank you!