External object name Not Acceptable for Informatica odata source

  • 1
  • Problem
  • Updated 2 years ago
  • Solved
I am trying to setup skuid to use Odata1-3 to connect to a Informatica realtime odata source that is connected to SQL server. When selecting the External Object Name, I get the Not Acceptable error message. I used the same Informatica end point with Lightning Connect and it was able to retrieve and sync all my tables.
https://ps1w2.rt.informaticacloud.com...

My initial guess is that maybe Skuid is not compatible with Odata V4?
Photo of George Wu

George Wu

  • 100 Points 100 badge 2x thumb

Posted 2 years ago

  • 1
Photo of Amy Dewaal

Amy Dewaal, Official Rep

  • 8,200 Points 5k badge 2x thumb
George,

What version of Skuid are you on? As of the Brooklyn GA release, Skuid should work with Odata 4. 

Thanks!
Amy
Photo of George Wu

George Wu

  • 100 Points 100 badge 2x thumb
I am using 8.15.8, Rockaway Iteration 10, what was installed from appexchange.
Photo of Amy Dewaal

Amy Dewaal, Official Rep

  • 8,200 Points 5k badge 2x thumb
George,

That's probably the issue then! Before the Brooklyn release Skuid only supported Odata 1-3. If you'd like to connect through Odata 4 try updating to a Brooklyn release. Brooklyn Iteration 1.1 is available at Skuid's Releases page. As a reminder, Salesforce does not allow reverting back to prior versions of managed packages. Skuid always recommends installing new versions in a non-business critical sandbox environment to test all mission critical functionality before installing into a production environment. 

Thanks!
Amy
Photo of George Wu

George Wu

  • 100 Points 100 badge 2x thumb
Hi Amy,

I installed Brooklyn Iteration 1.1. When selecting External Object Name, the icon in the field just keeps spinning. I have no problem if I use the Northwind data source.

Thanks,
George
Photo of Amy Dewaal

Amy Dewaal, Official Rep

  • 8,200 Points 5k badge 2x thumb
George,

I just learned you also need a custom configuration in the data source of odata-version: 4.0 for the connection to work:



Does adding this help?

Thanks!
Amy
Photo of George Wu

George Wu

  • 100 Points 100 badge 2x thumb
Yes. The setting solved the problem. Thanks!