Exported theme using odd extension and "erased" my theme.

  • 1
  • Problem
  • Updated 1 year ago
  • Solved
Hello all,

I have been working on a theme in our orgs sandbox and then attempted to export it and import into our production org. When exporting the file a file with the extension .sktheme was downloaded (not a .zip like the documentations says). When uploading this into production the theme appears in a row with the proper name and meta data listed but when I attempt to open the theme the page is stuck loading the theme builder. Also when I set a page to use the theme some ugly monstrosity appears rather than the theme I built. 

Not only this but it seems the original theme in the sandbox has been erased as well. The theme is still there in its row but all pages using the theme have reverted to the default design (also cannot open it in theme builder). 

Any ideas what happened or if I can recover this theme from the file I have? Thats a couple hours designing down the drain...
Photo of Michael Schniepp

Michael Schniepp

  • 1,808 Points 1k badge 2x thumb

Posted 1 year ago

  • 1
Photo of Mark DeSimone

Mark DeSimone, Official Rep

  • 11,050 Points 10k badge 2x thumb
Hi Michael. I'm sorry to hear that you've run into this frustrating issue. The .sktheme extension is nothing to be suspicious about; Skuid themes no longer have the .zip extension, but the actual file format is the same as a zip file. So, you can technically rename an old theme file to have the .sktheme extension instead of .zip. I will make sure our documentation gets updated to reflect this change - thank you for bringing it to our attention!

Regarding your theme issues, I have a few questions:
  • Have you made sure your themes are up to date? When you import themes, you sometimes need to re-run the "Update out of date themes" process to bring the imported theme up to date with the Skuid version you've got in your org. You would see the "Update out of date themes" button appear on your themes page if this was the case. 
  • Which version of Skuid are you working with? There was a product issue that prevented the theme builder from loading in Firefox. This would have been resolved in Skuid version 10.0.3 (look for issue CORE-399 on the releases page). Before making any upgrades to your Skuid version, you would of course want to thoroughly test a new version in a non-mission critical sandbox, as Salesforce does not allow reverting managed packages like Skuid to old versions.
  • When you say the original theme has been erased, can you elaborate? Was this one of the pre-built base themes? If so, which one?
Photo of Mark DeSimone

Mark DeSimone, Official Rep

  • 11,050 Points 10k badge 2x thumb
When you try to enter the editor for this imported theme, can you try this?
Edit your theme - if theme loader is stuck loading (and the UI is frozen), open your browser console. If in Chrome, you can click and hold down the refresh button, to see a few refresh options. Choose to "Empty Cache and Hard Reload." This has helped with similar issues in which the theme loader won't load completely. 

You had mentioned that the theme looks different in your sandbox than it did before - Would you mind looking at the theme file you imported into your Prod org, and check the file size? It should be a few hundred kilobytes, I believe. I'm wondering if you'd be able to re-export the source theme, now that you have the permissions settings necessary for theme management, to see if the exported file looks different. 
Photo of Michael Schniepp

Michael Schniepp

  • 1,808 Points 1k badge 2x thumb
Empty Cache and Hard Reload yielded the following error:


Here is the uploaded theme detail:


Upon export of the same resource I got a file of size 393 bytes
Photo of Michael Schniepp

Michael Schniepp

  • 1,808 Points 1k badge 2x thumb
I am making the theme again. I think something funny happened the first time as I made it off of a cloned theme. 
Photo of Michael Schniepp

Michael Schniepp

  • 1,808 Points 1k badge 2x thumb
I was successful in recreating the theme then importing and exporting. I believe something happened when using a cloned theme. 
Photo of Mark DeSimone

Mark DeSimone, Official Rep

  • 11,050 Points 10k badge 2x thumb
Thank you for sharing this update. I'm glad you were successful, but sorry that you had to recreate your theme. If you run into anything similar please let us know.