Error Packing and Unpacking Page Assignments (Banzai)

  • 1
  • Problem
  • Updated 3 years ago
  • Solved

This is the error I get when I try to pack the page assignments

Also when I try to unpack a previous version pack of assignments:

Photo of Pablo Martinez

Pablo Martinez

  • 2,468 Points 2k badge 2x thumb

Posted 3 years ago

  • 1
Photo of Pablo Martinez

Pablo Martinez

  • 2,468 Points 2k badge 2x thumb
Also, I cannot change 'applies to' in the Page assignments It's allways Organization Default
Photo of mB Pat Vachon

mB Pat Vachon, Champion

  • 42,674 Points 20k badge 2x thumb
That's strange. What version of Banzai?

I'm running version 7.16.

Looks like you're using Chrome. Not sure that would be the issue, but I'm running version 45.0.2454.101 m.

My guess would be that you're running an older version of Banzai.
Photo of Pablo Martinez

Pablo Martinez

  • 2,468 Points 2k badge 2x thumb
I'm using Skuid 7.16

And Chrome Version 46.0.2490.52 beta-m (64-bit)
Photo of mB Pat Vachon

mB Pat Vachon, Champion

  • 42,674 Points 20k badge 2x thumb
hmmm... maybe downgrade Chrome from beta and/or try another browser.
Photo of Pablo Martinez

Pablo Martinez

  • 2,468 Points 2k badge 2x thumb
With IE11 unpacking does not show error but it's been 10 minutes unpacking 7 assignments and still not finished...

Same packaging new ones
Photo of Pablo Martinez

Pablo Martinez

  • 2,468 Points 2k badge 2x thumb
Ok, solved, 

No user was with the skuid permission sets... No idea why...
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
That is a whacky situation.  Sorry it threw you.  Glad you got it fixed. 
Photo of Craig Rosenbaum

Craig Rosenbaum

  • 4,776 Points 4k badge 2x thumb
Just had this same thing happen when updating a trial account to banzai and uploading a new package. Any idea why the system admin account wouldnt have the Skuid Admin Permission set?
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
Usually this happens in a really old Skuid org.  If Skuid was installed before like v2,  permission sets were not used and we set up direct access to objects for admins.  This doesn't scale well - which is why we went to the permission sets. 
Photo of Craig Rosenbaum

Craig Rosenbaum

  • 4,776 Points 4k badge 2x thumb
Weird, I think the our TSO was on 6.8 something. I'll just make sure that the account has that setting in there and it shouldn't be a problem.