Error on fields not accessible by current users profile. 10.0.10 update to 11.1.7

  • 1
  • Problem
  • Updated 8 months ago
  • Solved
"A Skuid Model, 'Members', requested a Field with relationship name 'DoNotCall', on the Contact Object, but Skuid could not find a valid Field accessible through this relationship name. Please check that this Field actually exists on this Object (or on any related Objects). If it exists, then ensure that the user has permission to access it. If it does not exist, remove it from this Model."

The fields do exist but the users profile isn't set to have access to them. It used to be that the field would simply not display. This was desired. Otherwise we'd have to create multiple versions of the page based on the user profiles. Really not desired.

Now there's an error for each field a user doesn't have access to.

Is there a setting for this to be enabled/disabled?

Photo of mB Pat Vachon

mB Pat Vachon, Champion

  • 42,714 Points 20k badge 2x thumb

Posted 8 months ago

  • 1
Photo of Chandra V

Chandra V, Champion

  • 6,966 Points 5k badge 2x thumb
We had this - saw in the release notes that this is for Admins / Skuid Page Builders only, just to let you know that the model is querying a field that your page builders don't have access to.  For us, in showed us a place where a field was inaccessible by system admins, yet needed in the page (that is bad.)  So, if a page builder selects a field to query in a model, then the page builder should have access to it.  Or not... but the page is just alerting you to that.  The user side of the page doesn't change.

As of Millau 11.1.3, we now report inaccessible fields as Page Problems to aid Page Builders in resolving inconsistencies between the Page Composer and the runtime. Users with Skuid Admin or Skuid Page Builder permissions may now see Page Problems. This does not represent any change in behavior for standard Skuid users.