Editable fields in the form editor

  • 1
  • Question
  • Updated 2 months ago
  • Answered
I have a form editor within a Wizard and all the fields are editable. I have to click on edit sign next to the field for the text box to show up. I want the text box to show automatically instead of the user having to click on the edit sign.

Another question is that one of the fields has a default value of 1001 and is showing as 1,001. How can I remove the comma in the default and entered value?
Photo of Fireveo

Fireveo

  • 240 Points 100 badge 2x thumb

Posted 2 months ago

  • 1
Photo of Mike Dwyer

Mike Dwyer

  • 3,330 Points 3k badge 2x thumb
On your first question, you probably need to set the Default Mode property of the Field Editor component to Edit. It is probably Read with Inline-Edit by default.

As to the second, it might get more complicated. My assumption is that your field is defined in Salesforce as a Number datatype. What you can do in the skuid model is select the "Override field metadata" checkbox for the field properties and set the Return Type to Text. This will affect every place you use the field, from that model, in that page. For now, let's hope that is satisfactory.
Photo of Fireveo

Fireveo

  • 240 Points 100 badge 2x thumb
Thanks for your response. I am totally new to skuid so it helps. First question is resolved but for the second, I do not see in skuid model the "Override field metadata" checkbox in the field properties? 
(Edited)
Photo of Mike Dwyer

Mike Dwyer

  • 3,330 Points 3k badge 2x thumb
Our page-builders/designers may look different, but this screen grab may help:


You will get more options on the right after you click the checkbox.
(Edited)
Photo of Fireveo

Fireveo

  • 240 Points 100 badge 2x thumb
Got it. I did Override field metadata and changed display type to text. It now displays as 1001.0

I want it as 1001 and don't need to display the .0
Photo of Mike Dwyer

Mike Dwyer

  • 3,330 Points 3k badge 2x thumb
Hmm. I groping in the dark a bit. Is the field defined as Number (18,1) on the Object? If so, is it a field whose definition you can change? (I work strictly with custom objects and fields, so if you are using standard Salesforce objects I may have a different perspective.)

Depending on the nature of the field, if you can't change its definition, you may be able to create a Formula field on the SF side, or look into UI-Only fields on the Skuid side. 
Photo of Fireveo

Fireveo

  • 240 Points 100 badge 2x thumb
I tried putting the Default Value to 1001 with the display type of text in skuid model and it works. Thanks for your help.