Dropbox REST Tutorial - Stuck on Step "Configure Model to retrieve Dropbox file and folder metadata"

  • 1
  • Problem
  • Updated 1 year ago
  • Solved
I think maybe that the tutorial was based on Dropbox's API V1 whereas creating an app now uses API V2. As such I think there are issues in the tutorial in relation to this as it's expecting V1. I tried altering the URL to all be https://api.dropbox.com/2/ vs https://api.dropbox.com/1/ but when testing the skuid page I get the following error:



Going with the tutorial I get the same message except "https://api.dropbox.com/1/metadata/dr..." on the first line.
Photo of mB Pat Vachon

mB Pat Vachon, Champion

  • 42,714 Points 20k badge 2x thumb

Posted 3 years ago

  • 1
Photo of Stephen Sells

Stephen Sells, Official Rep

  • 16,856 Points 10k badge 2x thumb
Official Response
Hello Skuid Community ~

Thank you for your patience! Skuid implemented a fix in the new Brooklyn (10.0.3 & 9.5.10) release which is now available on the Skuid Releases page.

As a reminder, Salesforce does NOT allow reverting back to prior versions of managed packages. Skuid always recommends installing new versions in a non-business critical sandbox environment to test all mission critical functionality before installing into a production environment. We also recommend that you update out of date themes when you upgrade.