Distance model condition not filtering in Skuid 8.8

  • 1
  • Problem
  • Updated 1 year ago
  • Solved
  • (Edited)
Hi, we want to filter a model, based on the distance on two locations. (According to this tutorial http://help.skuid.com/m/models-conditions-filters/l/378314-distance-conditions)

However, it doesn't seem to update correctly.

We tried it in 7.36 it works fine, but NOT on the Account object. 
Currently we use Skuid 8.8. and we tested it in 8.10 aswell.

EDIT: To mention, it is in a sandbox org. And the 7.36 is a production org.
Photo of Thimo

Thimo

  • 1,280 Points 1k badge 2x thumb
  • bullied by Rockaway

Posted 2 years ago

  • 1
Photo of Karen Waldschmitt

Karen Waldschmitt, Official Rep

  • 8,240 Points 5k badge 2x thumb
Thimo~

We are able to reproduce what you are seeing and have notified the developers of this. We will let you know when this is fixed on a future release.

Thanks again for helping us make Skuid a better product!
Karen
Photo of Zach Gray

Zach Gray

  • 30 Points
Hi, I am also having an issue with Distance filtering. I can get it to work for standard objects like Account, but when trying to do a Distance filter with a Geolocation field on a custom object, it's not working. My problem is exactly like this other post: https://community.skuid.com/skuid/top...

Is this still an issue with this version of Skuid? Are there any workarounds, or do I need to write custom VisualForce to fix this?
Photo of Karen Waldschmitt

Karen Waldschmitt, Official Rep

  • 8,240 Points 5k badge 2x thumb
Zach~

Sorry, this is still a bug at the moment ... We will update this post when a fix is available. 

Thanks!
Karen
Photo of sumit

sumit

  • 428 Points 250 badge 2x thumb
Hi Thimo

The issue is resolved in SKUID version 10.0.3. Now We are able to perform distance search based on Geolocation fields.

Thanks,
Sumit