Details page not loading consistently

  • 1
  • Question
  • Updated 4 years ago
I have 2 queues, Accounts and Contacts for viewing related contacts' details.  The page include loads the contact details the first time I select a contact from the queue without any issues.  After that, it does not load again unless I do a page refresh. What can I do to solve this?  Thanks  
Photo of Denya Lloyd

Denya Lloyd

  • 570 Points 500 badge 2x thumb

Posted 4 years ago

  • 1
Photo of Zach McElrath

Zach McElrath, Employee

  • 49,056 Points 20k badge 2x thumb
A shot in the dark here would be to check that the names of your Models in your Queue and Detail page are different, e.g. in the main / parent page that has the Queue, called the Model "Accounts_Queue", and the Contacts Model, "Contacts_Queue". If the names of Models are identical in the parent and included pages, this error could happen.
Photo of Denya Lloyd

Denya Lloyd

  • 570 Points 500 badge 2x thumb
Thanks for your suggestion Zach but unfortunately it does not seem to be that simple this time.  Would anyone from your team be able to login and help me figure this one out.   Thanks
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
Denya.  Can you follow the instructions in this document to grant Login Rights for us at Skuid. 
http://help.skuidify.com/m/getting-started/l/182412-getting-help-how-to-grant-skuid-login-rights-to-...

We'd be happy to check out what is going on... 
Photo of Denya Lloyd

Denya Lloyd

  • 570 Points 500 badge 2x thumb
Hey guys,  I have been out for a while but I still need your help with my "view contacts by accounts" tab, not loading details, its located under my address book. Let me know what you find.  You now have access. Thx
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
There was a problem with your query string in the page where you show the contacts for a particular account, and want to select the details for a single contact.  You had written the query string  id={Id}  (single braces).  Skuid can't interpret that..  It should be id={{{Id}}}  (triple braces).  I fixed the issue for you and things should be working.