Deployment to specific users only not working

  • 1
  • Question
  • Updated 2 years ago
  • Answered
  • (Edited)
Hi, I want to deploy my first page (Account View) to a specific user. I created the page, set up the VisualForce page and override. The user can see the Skuid page and everything works for them BUT the rest of the org is now getting an "Insufficient Privileges You do not have the level of access necessary to perform the operation you requested. Please contact the owner of the record or your administrator if access is necessary. For more information, see Insufficient Privileges Errors."

In my page assignments, I have an entry for the specific user, and an entry for the organizational default (so all other users from my understanding?). Why can't my other users see the standard account page?

Thanks!
Photo of Kris

Kris

  • 190 Points 100 badge 2x thumb

Posted 2 years ago

  • 1
Photo of Bill McCullough

Bill McCullough, Champion

  • 12,436 Points 10k badge 2x thumb
Kris,

Does the rest of your org have access to the VisualForce page that you added?  They need it so that Skuid's 'redirect' will work.

Thanks,

Bill
Photo of Kris

Kris

  • 190 Points 100 badge 2x thumb
They did not as that was not mentioned in the tutorial. Thank you so much, it works now!

If a moderator is reading this, any chance this could be added here: http://help.skuid.com/m/getting-started/l/102646-deploy-different-pages-to-different-profiles-in-dif...

Thank you again!
Photo of Stephen Sells

Stephen Sells, Official Rep

  • 16,856 Points 10k badge 2x thumb
Thank you for bringing that to our attention Kris