De-reference a null object error when review skuid page in PageBuilder

  • 1
  • Question
  • Updated 2 months ago
  • Answered
In our current new Salesforce 19 instance partner dev org, we install 11.2.8 skuid. However, whatever the skuid pages we import in we are not able to see in page builder. The error message is below when we open the page:

Attempt to de-reference a null object 

An unexpected error has occurred. Your solution provider has been notified. (skuid)

The org id is 00D2v000001urNh. Can you guys urgently have a look at this? Thanks very much.
Photo of Mandy Zeng

Mandy Zeng

  • 194 Points 100 badge 2x thumb

Posted 2 months ago

  • 1
Photo of Luzie Baumgart

Luzie Baumgart, Official Rep

  • 3,704 Points 3k badge 2x thumb
Hi Mandy, since this is a new org, could you please double check license and permission?
https://docs.skuid.com/latest/en/skuid/deploy/salesforce/user-access/
Photo of Mandy Zeng

Mandy Zeng

  • 194 Points 100 badge 2x thumb
Hi Luzie,

At this moment, we only have one user in this new org which is Admin user with Skuid Admin/Skuid Page Builder/Skuid Page Viewer permission Set already.

Beyond that, this user also has Skuid license


After I went through your document, I also set the Page and Page Assignment Sharing Rules to be Public Read Only, but there is still no luck.
When I open any page by click that link to go to page builder like below:

I get this:

I already grant the login access to this org for one week. The org id is 00D2v000001urNh. Can you please help me to work this out?

Thanks
Photo of Khamla Phimmachack

Khamla Phimmachack, Official Rep

  • 1,976 Points 1k badge 2x thumb
Thanks for providing access Mandy, we were able to confirm your permissions look fine. We're circling internally with our team for any clues and will provide an update once we have progress.

Thanks,
Khamla
Photo of Khamla Phimmachack

Khamla Phimmachack, Official Rep

  • 1,976 Points 1k badge 2x thumb
Hi Mandy,

We were able to determine that one of your custom Component Packs was causing the problem. In Skuid Central, if you go to Configure -> Component Packs you will see a component pack that is not part of Skuid's namespace. We disabled this and it seemed to resolve the problem. Let us know if you can confirm. 

Please see the following docs on Component Packs that may help you determine why the pack is causing the error message:
https://docs.skuid.com/latest/en/skuid/components/original/build-component-packs.html#errors-messages

Thanks,
Khamla
(Edited)
Photo of Mandy Zeng

Mandy Zeng

  • 194 Points 100 badge 2x thumb
Hi Khamla,

Thanks for pointing that. I will work on this internally. Appreciate your work.