customer Skuid Community broke with Summer 16

  • 1
  • Problem
  • Updated 2 years ago
  • Not a Problem
Urgent problem, as our customer community is down and they are heavily reliant on it to obtain their order and shipment statuses.

We were upgraded to Summer '16 over the weekend and we run a SF community using VF pages that redirect to Skuid pages.

We have a custom domain, mycommunity.com and use the "other situation" page assignments to redirect users to the branded Skuid page instead of the Internal Skuid page.  That previously worked great.  The user would click on the Name field of a record, and see the record with a visible url of mycommunity.com/<recordID>.  All was great.

Now, the url has mycommunity.com/s/detail/<recordID> and the user gets a url not found error.  Manually taking out the /s/detail creates a redirect back to the /s/detail page, and thus the same error.  So our community users can't access any detail pages at all... which is a big problem for us.  


This is happening in my sandbox (on Rockaway) and in Production (On Banzai.)

Any help would be appreciated!!
Photo of Chandra V

Chandra V, Champion

  • 6,966 Points 5k badge 2x thumb

Posted 2 years ago

  • 1
Photo of Chandra V

Chandra V, Champion

  • 6,966 Points 5k badge 2x thumb
UPDATE: works fine for a System Admin, but not for the Partner Community profile.  I have confirmed the Partner profile has access to the Page Assignments object (read access, plus read on all fields) and the Skuid Re-directs apex class.
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
Would you mind giving us login rights to your org so we can take a look at what is going on?  


Please send an email to support@skuid.com with the following information: 

1. Your Org ID
2. Name of a community user that we can use to test. 
3. Steps to be used to repro the problem. 
4. At least one Skuid pages that is being used. 
Photo of J.

J., Official Rep

  • 7,470 Points 5k badge 2x thumb
Chandra,

Would you grant us access to the Sandbox instance that is having the issue and forward that Org ID to support@skuid.com? Thanks.
Photo of Chandra V

Chandra V, Champion

  • 6,966 Points 5k badge 2x thumb
Info was sent... if you don't have it, please let me know.  thanks so much!
Photo of Chandra V

Chandra V, Champion

  • 6,966 Points 5k badge 2x thumb
To anyone who finds this thread: This was a Summer '16 issue, and completely not Skuid related.  It affects anyone who uses a Visualforce Community, rather than Site (template) based.  Which I think would include everyone who has a Skuid page community like we do.

The fix that Salesforce provided was easy and worked!  See the attached SF Community thread for details:

View/Comment
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
Thanks for letting us know.  Hope the underlying issue gets fixed soon.