custom popup layouts disappear

  • 1
  • Problem
  • Updated 4 years ago
  • Acknowledged
This has happened several times in the last few days.
Have a form open on 2 tabs, one in design, the other in preview
add components to a custom popup, save
refresh other page.... look at custom popup... see new components
go back to page open in design, open same popup... all components are gone


Photo of ktyler

ktyler

  • 9,244 Points 5k badge 2x thumb

Posted 4 years ago

  • 1
Photo of ktyler

ktyler

  • 9,244 Points 5k badge 2x thumb
Here's a screen shot for you... this is a pretty serious problem. This had 2 page titles and a field editor with 6 fields on it
(Edited)
Photo of J.

J., Official Rep

  • 7,470 Points 5k badge 2x thumb
Ken,

Thanks for alerting us. This looks like a bug, and I was able to replicate it in our dev org. It only seems to be affecting the Calendar Event popups though (Table Row and Page Title Button popups are unaffected). In any case, we're on it.
(Edited)
Photo of J.

J., Official Rep

  • 7,470 Points 5k badge 2x thumb
Ken,

I think I've got a workaround for you in the meantime. If you add an Event Template before you build out your popup, it seems to address the issue:



It can be anything, but the default is...
{{Name}}{{Model.label}}
If you look at your page XML and see that you still have stuff there that just isn't showing (that you don't want to rebuild anyway), try adding the following as the first child of the eventsource node (should be just above the onclickpopup node):
<eventtemplate>{{Name}}{{Model.label}}</eventtemplate>

(Edited)
Photo of J.

J., Official Rep

  • 7,470 Points 5k badge 2x thumb
Actually, I misspoke: there is no default. If you are trying to use this workaround, realize that whatever you specify here is what will show on your Calendar. If you are just using a Name Field property, then you'll need to put it in template format here. In other words, if you are using Subject for your Name Field, the value of Event Template should be...
{{Subject}}
Photo of ktyler

ktyler

  • 9,244 Points 5k badge 2x thumb
Thanks for the quick work J.
Now if I can just figure out what's going on with the IndexOf error I also posted yesterday I'll be back in business.

You can sure build wonderful stuff with SKUID
Photo of J.

J., Official Rep

  • 7,470 Points 5k badge 2x thumb
I just realized that I never actually mentioned this, but the issue seems to be limited to Page Title components. If you aren't using a Page Title in your popup, then you should be good. Also, that bit about the default value for the Event Template wasn't completely accurate: that's the default for Page Title components. There is no default for calendar events.

In other words, don't fill that value in unless you 1, are actually using it, or 2, need to use this as a workaround to get your popup builder back.
(Edited)