Custom Component Caching?

  • 1
  • Problem
  • Updated 5 years ago
  • Solved
I am having some trouble when trying to build a custom component.

I have a AntPlayBuildersJS static resource which is picking up changes to the code correctly.
However, changes to the AntPlayJS static resource do not seem to be getting picked up when i preview the page.

When I look in the chrome debugger, I see a reference to:

But opening up this file does not contain my latest saved version (it does show the latest version when I view the static resource and via ecipse).

Is this a version that is being cached in the skuid instance?
Is there a way to force skuid to re-read from the latest version of the AntPlayJS file?

Thanks
Photo of Ant Belsham

Ant Belsham

  • 1,022 Points 1k badge 2x thumb

Posted 5 years ago

  • 1
Photo of Ben Hubbard

Ben Hubbard, Employee

  • 12,490 Points 10k badge 2x thumb
Hi Ant,

In the page builder, when you click on your included static resource is the "Cache Resource Location" checkbox checked? If you un-check that, Skuid should stop using the cached location of your static resource. Let me know if this works.
Photo of Ant Belsham

Ant Belsham

  • 1,022 Points 1k badge 2x thumb
Thanks Ben.

What I had missed was the fact that I had to include the AntPlayJS file as a static resource in my skuid page. I had assumed from the examples that this was automatically getting picked up (i.e. like the AntPlayBuilders file is). Which is seems to partly do?

When i include the file as a static resource within the skuid page it works when I make changes - so all good.

Thanks for your help.