Custom object's history (field tracking) object not showing.

  • 1
  • Problem
  • Updated 4 years ago
  • Acknowledged
I'm trying to create a model for one of my custom object's history. When I go to create a model I can find the history object of all the standard objects and even the __History objects for Skuid's objects but my custom object's (PO_Item__c) history object is not coming up (expected: PO_Item__History).

I have verified that this object exists in the developer console and there are even records in it, but I just can't get it to appear in the model SObject picklist.

Any ideas?
Photo of Charles Zink

Charles Zink

  • 388 Points 250 badge 2x thumb

Posted 4 years ago

  • 1
Photo of mB Pat Vachon

mB Pat Vachon, Champion

  • 42,714 Points 20k badge 2x thumb
Is track field history set in the object settings?

Photo of Charles Zink

Charles Zink

  • 388 Points 250 badge 2x thumb
Yes it is
Photo of mB Pat Vachon

mB Pat Vachon, Champion

  • 42,714 Points 20k badge 2x thumb
The API name of your object is confirmed to be "PO_Item__c"? I've got one object where the API name and Label are not the same.

Photo of Charles Zink

Charles Zink

  • 388 Points 250 badge 2x thumb
Yep. I'm convinced this is some freak glitch with this specific object as all my other custom objects (including SO_Item__c haha) seem to have made __History available to Skuid.
Photo of Emily Davis

Emily Davis, Employee

  • 3,502 Points 3k badge 2x thumb
Hey, Charles,
If you want a second pair of eyes to look at it, do you mind giving Skuid login access to your org? Not sure why the object isn't showing in Skuid.
Emily