css external resources missing

  • 1
  • Problem
  • Updated 2 years ago
  • In Progress
I had css external links in my theme.  I changed a field in my css yesterday and saved.  I then noticed today that formating was failing.  Somehow my external css resources are now missing and I did not delete them.  I do not remember the linked resources.  Is there a method to recover the version I had yesterday afternoon?
Photo of Bill Fox

Bill Fox

  • 7,934 Points 5k badge 2x thumb

Posted 2 years ago

  • 1
Photo of Janick

Janick

  • 916 Points 500 badge 2x thumb
Bill

I've got some questions to get started on your case:
On what version of Skuid are you?
Have you upgraded the version lately?
In what form have the CSS resources been available? Are those static resources in Salesforce? If so, can you identify the resources by looking through them in Salesforce setup and reconnect them?

Thanks,

Janick
Photo of Bill Fox

Bill Fox

  • 7,934 Points 5k badge 2x thumb
Yes.  I had upgraded from Rockaway Point Release - Iteration 13.1 to Brooklyn Iteration 2.  I found the missing ENTERNAL resources in an old sandbox.  This is what was missing

I have replaced the inline css, still not working as you can see on your iphone when you go to member.dorothy.com
Photo of Bill Fox

Bill Fox

  • 7,934 Points 5k badge 2x thumb
I went into css themes and noticed the inline css was again blank.  I have put the inline css external resources in the  fields but the "Save"  button is not available.
Photo of Bill Fox

Bill Fox

  • 7,934 Points 5k badge 2x thumb
Also, when I try to access  the edit theme it can take 15 minutes for "Loading Theme Composer" to disappear.
Photo of Bill Fox

Bill Fox

  • 7,934 Points 5k badge 2x thumb
I was able to get one inline css saved after about 5 minutes.  I went out of the skuid, signed back in and  inline css external resource was gone.
Photo of Janick

Janick

  • 916 Points 500 badge 2x thumb
Hey Bill

This is a bug already acknowledged and will be fixed with iteration 3.
We will check back with you when iteration 3 got released, if this is fine with you?

Janick
Photo of Bill Fox

Bill Fox

  • 7,934 Points 5k badge 2x thumb
Except, I had tested in a sandbox and I thought everything was working and I went live with the new Skuid version in production.  When will I3 be out?
Photo of Janick

Janick

  • 916 Points 500 badge 2x thumb
Bill~

Due to this issue with Spring 17, we are unable to put a date on when Iteration 3 will be available. We will update the community as soon as the case open with Salesforce is resolved. 

Thanks!
(Edited)
Photo of Bill Fox

Bill Fox

  • 7,934 Points 5k badge 2x thumb
I have update to I3 and the issue still exist on the iphone and Ipad.  Use my test credentials to recreate.
User Name:  bill.fox@dorothy.com 
Password:    222222
Photo of Bill Fox

Bill Fox

  • 7,934 Points 5k badge 2x thumb
The external links are missing and the formating issue still exists in Iphone and Ipad.   And then when I refresh I get "Loading Theme Composer" forever.
https://drive.google.com/file/d/0B409lhd9sYDcbzQ2LUhTMDRRVDg/view
Photo of Bill Fox

Bill Fox

  • 7,934 Points 5k badge 2x thumb
This reply was created from a merged topic originally titled External CSS Missing.

The external links are missing and the formating issue still exists in Iphone and Ipad.   And then when I refresh I get "Loading Theme Composer" forever.
https://drive.google.com/file/d/0B409lhd9sYDcbzQ2LUhTMDRRVDg/view