contact lookup field not displaying contacts

  • 1
  • Problem
  • Updated 1 year ago
  • In Progress
I'm struggling with a contact lookup not displaying the account contacts. In this specific scenario I'm logging an activity/task. The task is related to an Opportunity and I want to assign the customer contact to that task as well.

I have developed the ability to pre-populate the field with the primary contact. Where the issue is occuring is when I click the magnifying glass in that contact field. It displays a popup, but the lookup is going into all contacts in my org instead of just contacts on that account.

My Related Contact model is only pulling in contacts with the Id in the Account model.

How do I narrow the magnifying glass lookup?
Photo of Ryan Faust

Ryan Faust

  • 884 Points 500 badge 2x thumb

Posted 1 year ago

  • 1
Photo of Skuidward Tentacles (Raymond)

Skuidward Tentacles (Raymond), Champion

  • 17,224 Points 10k badge 2x thumb
When you click on the field in the layout, it will bring up field properties. You have properties for search and filters. Search gives you an option to search by model (at least it does in the latest version of Skuid). Filters allow you to apply specific conditions on what results are returned.
Photo of Ryan Faust

Ryan Faust

  • 884 Points 500 badge 2x thumb
Ok - so, I've changed the Search field property to = Model. However, the pop up continues to come back as blank. In the activity model I am bringing in all contacts on the account (at least I think I am). Any other ideas?