Console error related to proxy request

  • 1
  • Problem
  • Updated 1 year ago
  • Not a Problem
Skuid Team,

We updated our full sandbox to 10.0.0.10 from 8.15.17.  We are testing our pages and we found that we are consistently seeing an error in the console related to a Get request.  It is showing a 401 Unauthorized request error.  In the console we see a proxy request with the following URL: https://mydomain.visual.force.com/services/proxy?_=1509106726549

This is happening in production (still on 8.15.17).  In production this error is only adding ~100 ms of delay in page loading.  In the full sandbox, this error can add 3000 - 4000 ms of delay in page loading.  It seems worse with list views where we return multiple records.

The screenshots are from our Sandbox.  I created a simple contact detail page using the 'template' feature of the new page wizard.  The contact model on this page only loads 1 record and 1 field.
 
Any ideas on how we can fix this?

Thanks,

Bill

Photo of Bill McCullough

Bill McCullough, Champion

  • 12,436 Points 10k badge 2x thumb

Posted 1 year ago

  • 1
Photo of Zach McElrath

Zach McElrath, Employee

  • 49,004 Points 20k badge 2x thumb
Bill, the error you are reporting is not coming from Skuid code --- Skuid does not use `forcetk` and does not make requests to /services/proxy. Is there some logic you have running in a Sidebar component that uses ForceTK ?

Either way, I am pretty sure this is not coming from Skuid.
Photo of Bill McCullough

Bill McCullough, Champion

  • 12,436 Points 10k badge 2x thumb
Zach,

Thanks for your input on this.  While we do not have a custom Sidebar component, your clue led me to look at what browser extensions I have running (on Chrome).

The error came from an extension to delete debug logs from Salesforce.  Disabling the extension removed the console error.

Best,

Bill