Conditional rendering not updating when model is client side and marked to create row if none

  • 1
  • Problem
  • Updated 3 years ago
  • Solved
  • (Edited)
When a model is marked to process client side, NOT load data and create row if none, conditionally rendered elements are not updating as data for the conditions change.  

This issue is similar to others posted regarding client side processing and similar to issues seen in the past (6.x release & 7.x release) with conditional rendering on rows created when none.

Steps to repro:
1) Create page using sample XML
2) Preview page
3) Click "Update to Joe"

Expected
Name != Joe button disappears, Name = Joe apears Page Title updated to Joe

Actual
Name != Joe remains, Name = Joe does not appear, Page Title not updated

Sample Page XML
<skuidpage unsavedchangeswarning="yes" personalizationmode="server" showsidebar="true" showheader="true" tabtooverride="Account">   <models>
      <model id="Account" limit="1" query="false" createrowifnonefound="true" sobject="Account" adapter="" type="" doclone="" processonclient="true">
         <fields>
            <field id="Name"/>
            <field id="CreatedDate"/>
         </fields>
         <conditions/>
         <actions/>
      </model>
   </models>
   <components>
      <pagetitle model="Account" uniqueid="sk-3dXrcv-67">
         <maintitle>
            <template>{{Name}}</template>
         </maintitle>
         <subtitle>
            <template>{{Model.label}}</template>
         </subtitle>
         <actions>
            <action type="multi" label="Name = Joe">
               <renderconditions logictype="and">
                  <rendercondition type="fieldvalue" operator="=" enclosevalueinquotes="true" fieldmodel="Account" sourcetype="fieldvalue" field="Name" value="Joe"/>
               </renderconditions>
               <enableconditions logictype="and"/>
            </action>
            <action type="multi" label="Name != Joe">
               <renderconditions logictype="and">
                  <rendercondition type="fieldvalue" operator="!=" enclosevalueinquotes="true" fieldmodel="Account" sourcetype="fieldvalue" field="Name" value="Joe"/>
               </renderconditions>
               <enableconditions/>
            </action>
            <action type="multi" label="Update To Joe">
               <actions>
                  <action type="updateRow" fieldmodel="Account" field="Name" enclosevalueinquotes="true" value="Joe"/>
               </actions>
            </action>
            <action type="multi" label="Update To Steve">
               <actions>
                  <action type="updateRow" fieldmodel="Account" field="Name" enclosevalueinquotes="true" value="Steve"/>
               </actions>
            </action>
         </actions>
      </pagetitle>
   </components>
   <resources>
      <labels/>
      <css/>
      <javascript/>
   </resources>
   <styles>
      <styleitem type="background" bgtype="none"/>
   </styles>
</skuidpage>
Photo of Barry Schnell

Barry Schnell, Champion

  • 18,076 Points 10k badge 2x thumb

Posted 3 years ago

  • 1
Photo of Barry Schnell

Barry Schnell, Champion

  • 18,076 Points 10k badge 2x thumb
This appears to be working as expected in Skuid 7.16.  Can someone confirm if this was resolved in Update 2 or if there is still more work pending?  Thank you!
Photo of J.

J., Official Rep

  • 7,470 Points 5k badge 2x thumb
Yep, I can confirm that this is fixed as of 7.16. Sorry for the late notice!
Photo of Barry Schnell

Barry Schnell, Champion

  • 18,076 Points 10k badge 2x thumb
No worries J, thanks for confirming!