Condition Logic on Button Enable Issue

  • 1
  • Problem
  • Updated 2 years ago
  • Solved
Hi,

I am having a condition logic on my Button as Enable condition. But it does not seem to work. 
Below is the condition logic:

((1 AND 2 AND 3 AND 4 AND 12 AND 13) OR (1 AND 2 AND 3 AND 4 AND 5 AND 12 AND 14) OR (1 AND 2 AND 3 AND 4 AND 6 AND 7 AND 8 AND 9 AND 11 AND 13) OR (1 AND 2 AND 3 AND 4 AND 5 AND 6 AND 7 AND 8 AND 9 AND 10 AND 11 AND 14))

I also tried by changing it to :

(1 AND 2 AND 3 AND 4 AND ((12 AND 13) OR (5 AND 12 AND 14))) OR(1 AND 2 AND 3 AND 4 AND 6 AND 7 AND 8 AND 9 AND ((11 AND 13) OR (5 AND 10 AND 11 AND 14))) 

Conditions 1-10 are fields from Model 1 and Model 2, evaluating particular value from picklist.

Conditions 11 and 12 are reference to a lookup field from Model 3, evaluating whether its null or not.

Conditions 13 and 14 are fields from Model 3, evaluating name text.

Kindly let me know if I am using the logic wrong or do I need to consider the Conditions 1-10 (reference to picklist fields) in some other way.

Thanks!
Photo of Prachi

Prachi

  • 226 Points 100 badge 2x thumb

Posted 2 years ago

  • 1
Photo of Karen Waldschmitt

Karen Waldschmitt, Official Rep

  • 8,260 Points 5k badge 2x thumb
Prachi~

Are you still having difficulty with this? I heard you may have figured it out already. If so, would you be willing to share your solution with the community?

Thanks!
Karen
Photo of Prachi

Prachi

  • 226 Points 100 badge 2x thumb
HI Karen,

Sure. Actually I manually tried satisfying the conditions and figured out that one of the conditions was not getting satisfied and hence the custom condition was not working. So our client is currently working on that. Will test it thoroughly again and confirm if we still face the issue with enable conditions.

Thanks !