Components not showing after upgrading to version 7.27.1

  • 1
  • Problem
  • Updated 3 years ago
  • Not a Problem
  • (Edited)
Components not showing after upgrading to version 7.27.1

When I click on a page nothing is showing up.
Photo of Andrew Ottaru

Andrew Ottaru

  • 1,098 Points 1k badge 2x thumb

Posted 3 years ago

  • 1
Photo of Zach McElrath

Zach McElrath, Employee

  • 49,036 Points 20k badge 2x thumb
Andrew, this may be a caching issue. Can you do one or both of the following: 
1. Logout of Salesforce and quit your browser and reopen.
2. Hit "Command+Shift+R" to force the browser to refresh all JavaScript and CSS files used to request the page.
Photo of Andrew Ottaru

Andrew Ottaru

  • 1,098 Points 1k badge 2x thumb
Hi Zach, Unfortunately that did not solve the issue. Please see the image below.

<<Image Removed at Andrew's Request>> 
(Edited)
Photo of Zach McElrath

Zach McElrath, Employee

  • 49,036 Points 20k badge 2x thumb
Is there only a particular component that is not working, or all components? Is it just this particular tab in your page, or all tabs?
Photo of Andrew Ottaru

Andrew Ottaru

  • 1,098 Points 1k badge 2x thumb
All components are not showing up under all tabs. 
Photo of Zach McElrath

Zach McElrath, Employee

  • 49,036 Points 20k badge 2x thumb
Can you grant login access to Skuid Support and email us a link to this page as well as your org id / name of org where this is happening?

What components do you have in these tabs? Page Includes, or specific components?
Photo of Andrew Ottaru

Andrew Ottaru

  • 1,098 Points 1k badge 2x thumb
I have grant login access and send an email with my org ID and where the issue is happening.

Some components we have in those tabs are Chatter Feed, Tab Set, Field Editor we also have page include. Thanks
Photo of Zach McElrath

Zach McElrath, Employee

  • 49,036 Points 20k badge 2x thumb
Andrew, after examining your page, the issue is coming from JavaScript code in your page, not from Skuid. I sent you an email about how to adjust your JavaScript to fix this issue. For others' benefit, if you're experiencing problems with your Skuid Pages and you've got custom JavaScript written in those pages, do a quick check of the JavaScript Console on that page (Command+Shift+J in Google Chrome) to see if there are any errors coming from JavaScript you wrote on that page.