Component Pack files not loaded for component that exists on a popup

  • 1
  • Problem
  • Updated 2 years ago
  • Acknowledged
  • (Edited)

When a component from a component pack is defined on a popup, the resource files for the component pack are not loading in to the page.  This results in the component not working as expected.

Notes

1) If a component from the same pack is included on the main page, the popup behaves as expected because the component pack files are loaded in to the page.

2) Issue will occur with any component pack so simply replace Popup Controller from TFG Component Pack on Account Model -> Create Row Action -> Show popup with a component from another component pack to reproduce using a different pack.

3) When the component isn't found, NO error of any type is made available.  At the very least, something should be output to the console indicating a component was attempted to be loaded but couldn't be found.

Steps to reproduce:

1) Download & install TFG Components based on instructions from https://community.skuid.com/skuid/topics/collapsible-wrapper-custom-component

2) Create page using XML below

3) Preview page

4) Click "Create Row" button

Expected Result

1) The "X" in the upper right corner of popup should not be visible and hitting "escape" key should not close popup.

2) runtime.js from TFG Components should loaded

3) In the case where the component isn't found (because runtime.js wasn't loaded) some type of error should be output

Actual Result

1) "X" is visible and "escape" key closes popup because the component pack was not loaded

2) runtime.js from TFG Component is NOT loaded but no error of any type is emitted

Sample Page XML

<skuidpage unsavedchangeswarning="yes" personalizationmode="server" showsidebar="true" showheader="true" tabtooverride="Account">
   <models>
      <model id="Account" limit="100" query="true" createrowifnonefound="false" sobject="Account" adapter="" type="">
         <fields>
            <field id="Name"/>
            <field id="CreatedDate"/>
         </fields>
         <conditions/>
         <actions>
            <action>
               <actions>
                  <action type="showPopup">
                     <popup title="New Popup" width="90%">
                        <components>
                           <tfg__popupcontroller uniqueid="sk-2MvBz8-103" hideclose="true" disableescape="true"/>
                           <template multiple="false" uniqueid="sk-2MvGDU-111">
                              <contents>"X" and Escape should be hidden/disabled but they are not because Component Pack files were not loaded</contents>
                           </template>
                        </components>
                     </popup>
                  </action>
               </actions>
               <events>
                  <event>row.created</event>
               </events>
            </action>
         </actions>
      </model>
   </models>
   <components>
      <pagetitle model="Account" uniqueid="sk-2MuKWQ-66">
         <maintitle>
            <template>{{Model.labelPlural}}</template>
         </maintitle>
         <subtitle>
            <template>Home</template>
         </subtitle>
         <actions>
            <action type="multi" label="Create Row" icon="sk-icon-add">
               <actions>
                  <action type="createRow" model="Account" appendorprepend="prepend" defaultmodefornewitems="edit"/>
               </actions>
            </action>
         </actions>
      </pagetitle>
   </components>
   <resources>
      <labels/>
      <css/>
      <javascript/>
   </resources>
   <styles>
      <styleitem type="background" bgtype="none"/>
   </styles>
</skuidpage>

Photo of Barry Schnell

Barry Schnell, Champion

  • 18,076 Points 10k badge 2x thumb

Posted 2 years ago

  • 1
Photo of Barry Schnell

Barry Schnell, Champion

  • 18,076 Points 10k badge 2x thumb
Skuid Team - Any insight on this?
Photo of Barry Schnell

Barry Schnell, Champion

  • 18,076 Points 10k badge 2x thumb
Skuid Team - Any insight on this?
Photo of Barry Schnell

Barry Schnell, Champion

  • 18,076 Points 10k badge 2x thumb
This issue was originally posted nearly 3 months ago but has yet to be acknowledged or commented on by the Skuid team.  Just tested with 9.3.1 and this issue still exists.

Can someone from the Skuid team please acknowledge/confirm/reject/comment on this?

Thank you!
Photo of Barry Schnell

Barry Schnell, Champion

  • 18,076 Points 10k badge 2x thumb
Can someone from the Skuid team please acknowledge/confirm/reject/comment on this?
Photo of Barry Schnell

Barry Schnell, Champion

  • 18,076 Points 10k badge 2x thumb
Skuid Team - Any insight on this?
Photo of mB Pat Vachon

mB Pat Vachon, Champion

  • 42,714 Points 20k badge 2x thumb
Looks like we are experiencing the same thing. A very basic "hello world" component isn't working on runtime. Remi can provide more details if need be.
Photo of Amy Dewaal

Amy Dewaal, Official Rep

  • 8,200 Points 5k badge 2x thumb
Barry,

Sorry we've been so unresponsive, and thanks for the details. I've been able to reproduce the problems that you described.
Photo of Amy Dewaal

Amy Dewaal, Official Rep

  • 8,200 Points 5k badge 2x thumb
Pat, 

Is your basic component not loading on the page or is it located in a Skuid popup (or is it in a custom popup)?
Photo of Barry Schnell

Barry Schnell, Champion

  • 18,076 Points 10k badge 2x thumb
Thanks for confirming Amy.  Assuming this is implied when you confirmed the repro but just want to be sure that you've filed a bug internally against this issue?  Assuming yes to that, can you mark this as "Acknowledged" please?

Thanks!
(Edited)
Photo of Amy Dewaal

Amy Dewaal, Official Rep

  • 8,200 Points 5k badge 2x thumb
Yep, if I (or anyone else on the Skuid team) has confirmed as a bug then we've also filed internally about it.
Photo of Barry Schnell

Barry Schnell, Champion

  • 18,076 Points 10k badge 2x thumb
Perfect.  Assumed as much but just wanted to be sure.  Thanks Amy!