Clone a Line Item and some Fields not listed in table

  • 1
  • Problem
  • Updated 3 years ago
  • Not a Problem
  • (Edited)
I need to clone a line item; however, I also need to clone some fields that are not listed in the table. Reason being is that we have a formula field that is a summation of a bunch of net rate fields, and a workflow rule that makes our amounts field equal to that summation.

Problem is when cloning records in-line, the amount is cloned yet the core net rates are not. So when the workflow rule runs on record creation/edit, it makes amounts equal to the sum of net rates which are zero. 

We need to be able to clone in-line records and have these net rates in the background clone as well, yet putting each of them in the table would take up too much screen real estate. 

Is there a way we can clone the in-line record as well as the background net rates so our rule works?

Also, we have snippets for cloning line items which work perfectly, we just need to work around that workflow rule so the In-Line clone function also clones the fields in the opportunity not listed in the table.
Photo of Erik Wahlberg

Erik Wahlberg

  • 2,156 Points 2k badge 2x thumb

Posted 3 years ago

  • 1
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
Erik.  The clone tool really clones all the data in the model.  Not just what is on the table.  So if you include the Net Rate fields in your models the cloning should work as you expect. 
Photo of Erik Wahlberg

Erik Wahlberg

  • 2,156 Points 2k badge 2x thumb
Ahhh yes that makes sense, and the fix worked, thanks so much! Will make sure to go back in the model and include all relevant fields so it clones everything.