chrome version 52.0.2743.82 m issue using skuid functions in console

  • 3
  • Problem
  • Updated 2 years ago
  • Not a Problem
Using Chrome version 52.0.2743.82 m.
Photo of mB Pat Vachon

mB Pat Vachon, Champion

  • 42,714 Points 20k badge 2x thumb

Posted 2 years ago

  • 3
Photo of Amy Dewaal

Amy Dewaal, Official Rep

  • 8,200 Points 5k badge 2x thumb
Hi Pat,

Are you still seeing this issue? We also experienced this problem when we updated to version 52, but it inexplicably went away after a few hours, so we're guessing Chrome changed something.

Thanks!
Amy
Photo of mB Pat Vachon

mB Pat Vachon, Champion

  • 42,714 Points 20k badge 2x thumb
Still an issue for me. What version are you running?
Photo of Amy Dewaal

Amy Dewaal, Official Rep

  • 8,200 Points 5k badge 2x thumb
Sorry Pat, I spoke too soon. It looks like something with Salesforce and Chrome is breaking the console. I'm on version 52.0.2743.8252 of Chrome and can't do any commands in console if I have a Salesforce header/footer or even just a Chatter component on my page. If I have just Skuid components I'm getting functionality back, though.

Thanks!
Amy
Photo of mB Pat Vachon

mB Pat Vachon, Champion

  • 42,714 Points 20k badge 2x thumb
Confirmed as well. Without Chatter or header/sidebar everything seems to work fine.

Skuid and Salesforce conflict then. Hmmm.... 
Photo of Matt Sones

Matt Sones, Champion

  • 31,478 Points 20k badge 2x thumb
Wow, this is frustrating! I didn't realize how much I rely on the console until I couldn't use it. :(
Photo of Matt Sones

Matt Sones, Champion

  • 31,478 Points 20k badge 2x thumb
My version says 52.0.2743.82 m (64-bit)
Photo of Amy Dewaal

Amy Dewaal, Official Rep

  • 8,200 Points 5k badge 2x thumb
Okay, thanks, and it looks like it's a Chrome issue because the console does work in Firefox
Photo of mB Pat Vachon

mB Pat Vachon, Champion

  • 42,714 Points 20k badge 2x thumb
Yeah. I forgot to mention that.

So it's when Salesforce Header/sidebar/chatter feed and Chrome are used.
Photo of Matt Sones

Matt Sones, Champion

  • 31,478 Points 20k badge 2x thumb
Why would it only break when the salesforce header/sidebar is on?
Photo of Amy Dewaal

Amy Dewaal, Official Rep

  • 8,200 Points 5k badge 2x thumb
I think it's because the problems are coming in with Salesforce and Chrome rather than Skuid and Chrome. For instance, I can't use my console on standard Salesforce pages. Are you able to use the Chrome console on standard Salesforce pages?
Photo of mB Andréas K.LeF

mB Andréas K.LeF

  • 1,244 Points 1k badge 2x thumb
Confirmed bug in Chrome 52. See: https://bugs.chromium.org/p/chromium/issues/detail?id=632305
   
This is fixed in Chrome 53, slated for September release in the general channel.

EDIT:

For developers I highly recommend setting yourselves up with Chrome Canary:

https://www.google.com/chrome/browser/canary.html 

I can confirm this bug is fixed and the console works as expected this posting in "54.0.2811.0 canary (64-bit)"
(Edited)