Child Relationship template field disappearing after table search

  • 1
  • Question
  • Updated 3 years ago
  • Answered
  • (Edited)
Hello, 

I have a 'Customer' as a master and 'Alias' as a child object. I need to display these Customer records along with their aliases in a table.I have created a child relationship template field of aliases and added that to the table. Seems to work great! :)

However, after using a table search box, it does not display aliases. Not sure what I am missing...Please help! 



Photo of Rupali G

Rupali G

  • 378 Points 250 badge 2x thumb

Posted 3 years ago

  • 1
Photo of Bill McCullough

Bill McCullough, Champion

  • 12,758 Points 10k badge 2x thumb
Rupali,

You may want to add the Id field to the table.  Then run your search again and verify that the Id's of the 2 rows you are looking at are the same.  This will rule out that you have 2 rows with the same test data except for their aliases.  This has 'bitten' me before when starting something new.

Let us know how it goes.

Thanks,

Bill
Photo of Rupali G

Rupali G

  • 378 Points 250 badge 2x thumb
Thank you, Bill. I tried adding Ids but no luck so far. It seems to work fine before search. Looks like, after applying a search those fields are not rendered back on screen until a page refresh happens. Clearing out search box does not seem to help even if empty search behavior is set to re-query the model. 
(Edited)
Photo of Ben Hubbard

Ben Hubbard, Employee

  • 12,490 Points 10k badge 2x thumb
Hi Rupali, it looks like this is a regression introduced in Update 7. We'll get a patch out for this as soon as possible. I'm guessing early next week. I'll let you know if I find any workarounds before then.
Photo of Rupali G

Rupali G

  • 378 Points 250 badge 2x thumb
Thank you, Ben. 
Photo of Ben Hubbard

Ben Hubbard, Employee

  • 12,490 Points 10k badge 2x thumb
Fix should actually be out tomorrow.
Photo of Rupali G

Rupali G

  • 378 Points 250 badge 2x thumb
Great! :) Thank you so much. Appreciate it and looking forward to it. 
Photo of Ben Hubbard

Ben Hubbard, Employee

  • 12,490 Points 10k badge 2x thumb
Banzai Update 7.2 is on the http://www.skuidify.com/skuidreleases page and should fix this issue.
Photo of Rupali G

Rupali G

  • 378 Points 250 badge 2x thumb
That was prompt! Thank you. :)