Chatter Popup for Task List

  • 1
  • Question
  • Updated 3 years ago
  • Answered
We have a table of all the latest tasks appearing on our home page so people can see what's going on.  I'd like to add two row actions - one that pops up the individual chatter post for that specific task, and one that pops up all chatter posts for the account the task is assigned to.  I was following the instructions here, but I get a "URL No Longer Exists" error message instead of loading the chatter feed.  Any idea how I can set it up correctly?

The table itself is based on the Tasks model - not sure if that makes a difference.

Thanks!

Photo of abfleis

abfleis

  • 392 Points 250 badge 2x thumb

Posted 5 years ago

  • 1
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
Hmm. I can get this to work for me.  It is an interesting idea.   And some additions made to Skuid in the Spring Release make it much easier than what Zach told Glen in the link above.  Here is how to get what you are after. 

1. In your row action popups - place a page include.   The query string for the page include will be somthing like  "  id={{Id}}"  
  • The first Id needs to match the condition you create on the included skuid page,  
  • The second id needs to match the field on your task model that you want to pass into the page.   If it is AccountId you should put it in triple braces " {{{AccountId}}}  "  so that just the data is passed, rather than the rendered reference field. 


2.  Build a skuid page that just has a page tile and the chatter component.  This should be the skuid page referenced in your page include in section 1 above.  It should use a condition that filters down to a single record using a URL parameter.   


Include a page title and the chatter feed component.  The model for the new page needs just to have ID,  and whatever you want to put in the page title. 


Then it just works... 



Let us know if you still have problems. 

Photo of Adam Johnson

Adam Johnson

  • 1,000 Points 1k badge 2x thumb
You know this is a great post when 2 years later it is still helping! Thank you!
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
Winning! 
Photo of abfleis

abfleis

  • 392 Points 250 badge 2x thumb
So I created the new page, but for some reason it doesn't pull anything up when I run a preview and select a task to fulfill the condition - just a blank window.  Also, it shows the Chatter header for some reason?




Photo of abfleis

abfleis

  • 392 Points 250 badge 2x thumb
Fixed the header by turning it off on the page settings, but it's still coming up blank.  Thanks!
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
Do you have any fields in your task model?  I think you will at least need Name and ID for things to work. 

Photo of abfleis

abfleis

  • 392 Points 250 badge 2x thumb
Yeah - I pulled in Id and Subject.
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
Would you mind giving us login rights to the org and telling us what Skuid page this is happening on? 
Photo of abfleis

abfleis

  • 392 Points 250 badge 2x thumb
Done!  I made a page called TaskChatter, and we're trying to get it set up on the Home page.

Thanks!
Photo of abfleis

abfleis

  • 392 Points 250 badge 2x thumb
And if you can figure out how to set up a separate button to pull in all chatter records for the account associated to the task in the table row, that would be awesome as well.
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
There are a few separate issues going on here. 

1.  You have not yet enabled chatter on the task object.   Go to setup - Feed Tracking  and add the Task object. 

2.  You are building a home page component,  so naturally you don't want the standard salesforce header.  But Chatter depends on a javascript file that is loaded with the header.  This means the page include mechanism described above will not work.  So in this case you have to go the "template with an iframe route".   In addition, we had to create a different "chatter VF page" in your org that removed the header but still called the right stylesheet files.  This has been done. 

3. I created an account button on the tasks for one of your tabs.  Check it out.  I think you will be able to propogate the concepts to other areas. 
Photo of abfleis

abfleis

  • 392 Points 250 badge 2x thumb
Awesome - thank you!
Photo of Jack Sanford

Jack Sanford, Champion

  • 8,322 Points 5k badge 2x thumb
I'm also having trouble getting the page include in a popup to work for a chatter feed. It works fine actually, but only for the very first popup after page load. If I try and open the popup for a second record in my table, or even for a second time on the first record, the area to post a message disappears. 

I actually went back and tried the old way to do this - had no idea a skuid__Social page even existed! - and that works fine: https://community.skuidify.com/skuid/topics/chatter_feed_in_popup

Here it is working for the first time a popup is clicked. My page include with a chatter feed is on top, the template with an iframe to skuid__Social below. 



Here it is after clicking a second popup. I added a field editor to my page include to make sure it was actually loading a record, and it is, But the area that should say "write something..." doesn't appear, and you can't make any of the chatter quick actions do anything. The template loading an iframe still works. 



I don't mind just using the template and iframe, works just fine for now. The only drawback is cosmetic - with the page include it auto sets the height of the popup so you don't have extra white space for few posts, or long scrolling for lots of posts.
(Edited)
Photo of Spencer Essey

Spencer Essey

  • 70 Points
I was able to get the Chatter Feed into the Page Include just fine but I am having an issue where the Chatter Actions/Feed will be fine on the first click and I can do everything as expected, but If I try to open the Chatter Feed for another record in the table all my Actions/Feed won't work until I refresh the page . Once the page refreshes I get to access the Feed for one more record and then I have to refresh again. Any ideas on how to fix this? Thanks!
Photo of Jack Sanford

Jack Sanford, Champion

  • 8,322 Points 5k badge 2x thumb
Same problem I was describing above. You can fix using the skuid__Social page in an iframe. Add this code to a Template component, and make sure the Template is assigned to the model for which you want to pull the record ID. 
<iframe src="{{$Site.Prefix}}/apex/skuid__Social?id={{{Id}}}" frameBorder=0 width="100%" height="600px"/>
The way I did it was with a row action that calls a pop-up, and I put my template into the popup. Being called from a row action means it should contain the context of that single row's record id. 

The {{$Site.Prefix}} part is unnecessary unless you have Partner/Customer Communities set up and want it to work in there as well. 
(Edited)