Case History "Action" Column To UI-Formula Field

  • 1
  • Question
  • Updated 3 years ago
  • Answered
I'm trying to re-create the "Action" column for Case History in Skuid & am running into a bit of trouble. Below is a screenshot of the action field which i'm creating in a UI-Only template field within Skuid.

 

My sample formula is;  "Changed " + {{Field}} + " From " + "Old Value " + "To " + "New Value"
This works fine when just using strings; however, when I replace the strings with fields {{OldValue}} and {{NewValue}} I'm getting this error message;

1. Invalid syntax for field formula: "Changed " + {{Field}} + " From " + {{OldValue}} + "To " + {{NewValue}}. SyntaxError: Unexpected identifier
I had thought the issue might have something to do with OldValue and NewValue being "AnyType" fields but i'm unsure why i'm running into issues when trying to include these fields. Any ideas / suggestions would be much appreciated.
Photo of Erik Wahlberg

Erik Wahlberg

  • 2,156 Points 2k badge 2x thumb

Posted 3 years ago

  • 1
Photo of Peter Kong

Peter Kong, Employee

  • 440 Points 250 badge 2x thumb
Hello Erik! 

I had a UI-only formula field running on a Case History Model with "Changed " + {{Field}} + " From " + {{OldValue}} + " To " + {{NewValue}} and it runs fine for me. May I get a screenshot of you encountering this error? Thanks!

Regards,
Peter
Photo of Erik Wahlberg

Erik Wahlberg

  • 2,156 Points 2k badge 2x thumb
Realizing now I was running this template on the Case and not Case History model. Same formula tested on Case History model works perfectly. 
Photo of Erik Wahlberg

Erik Wahlberg

  • 2,156 Points 2k badge 2x thumb
Update: The formula works but the syntax error is still coming up. Any ideas? I'm planning on leaving it as is since i'm the only one looking at case details; however, it'd be nice to get rid of the red on page. 

Photo of Peter Kong

Peter Kong, Employee

  • 440 Points 250 badge 2x thumb
Hmm, only things that come to my mind if that formula's being applied somewhere else unsuccessfully. Have you made any progress on that since this last post? Also, it might worthwhile to just clone that Page, run the clone and see if the error message exists there. 
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
Erik.  While this is not exactly a solution.  You should know that users that do not have the Skuid Builder permission do not see those red Skuid Errors.  So if you think your page is working,  you can just roll it out in confidence that the pesty error won't show...