Cannot read property 'split' of undefined

  • 1
  • Problem
  • Updated 3 years ago
  • Solved
I'm receiving a blank page with the page title at the top when I try to edit one of my pages via the editor.

I'm receiving this error in the console: "Cannot read property 'split' of undefined"

I can access the page via the XML link but am unsure what caused the issue. It was working and then I refreshed and it stopped working. Not sure what change I could have done to cause this. Any ideas?
Photo of Craig Rosenbaum

Craig Rosenbaum

  • 4,776 Points 4k badge 2x thumb

Posted 3 years ago

  • 1
Photo of Matt Sones

Matt Sones, Champion

  • 31,478 Points 20k badge 2x thumb
Craig,

Not sure what caused your issue, but I'd suggest using the page versions to find the last autosave that works, and go from there.
Photo of Craig Rosenbaum

Craig Rosenbaum

  • 4,776 Points 4k badge 2x thumb
Great idea Matt. I didn't notice I could still access page versions. Restored to a previous version without the error and will proceed as normal. 
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
Glad you got it worked out.  Those dang javascript errors.  So tough. 
Photo of Emily Davis

Emily Davis, Employee

  • 3,502 Points 3k badge 2x thumb
For what it's worth, I've run into something similar before. I was trying to name a model, was stopped mid-typing by an error message because I had two models with the same name, then tried to correct the model name. This caused page errors when previewing the page, and when I refreshed the page editor, I got a similar JS error. Yuck! Moral of the story? Avoid typing in the name of another model when creating a new model. Not sure if it's the same issue you were encountering, Craig, but it's a weird kink in Skuid to watch out for.
Photo of Barry Schnell

Barry Schnell, Champion

  • 18,076 Points 10k badge 2x thumb
Hi All - See item #3 in the post at https://community.skuidify.com/skuid/topics/configuring-odata-based-models-builder-cannot-load-page-....  It appears that there definitely at least a few issues that are causing page XML to fail during load in the builder. Seems related to the model properties.

The issue Emily encountered is similar in nature to what I encountered.  With that said, regardless of user input, my feeling is that Skuid shouldn't encounter unhandled exceptions.  Instead, it should do type & value checking and handle fail gracefully with an error message.  I can envision an admin spending several hours on a page only then as a last step, change something and end up losing all that work because of a simple typo in a model name field.  Possibly something to add to the backlog ;)
(Edited)