Cannot query a model with action that is tied to an external object after the model is initially loaded

  • 1
  • Problem
  • Updated 3 years ago
  • Not a Problem
I am having issues with querying a model via an action after initial model load when that model is tied to an external object (made visible via SF connect)  .  I have a “Model A” that is related to a custom object that is used to set a condition on “External Model B” Here is my sequence of events:

1)      Both Model A and External Model B are initially loaded and I can see correct data for both in two table

2)      I made a change to data in model A and Save and see changes in it’s table

3)      The next step in my multi step action queries “External Model B” but I see no change the table showing it’s data

a.       As a trouble shooting step, I added a button to query “External Model B” but I see no change to the table

b.      As a trouble shooting step, I added a button to empty model “External Model B” but I see no change to the table

c.       As a trouble shooting step, I have built actions trying to activate/deactivate model conditions but I see no changes in the table tied to “External Model B”

4)      If I reload my page, then the data is correctly shown in the table for “External Model B”

5)      Also, if I have not initially loaded the model via model attribute, then I can run the query of “External Model B” and data is loaded into the empty table.  But once loaded, I cannot requery the model.

Photo of Eric Tuggle

Eric Tuggle

  • 342 Points 250 badge 2x thumb

Posted 3 years ago

  • 1
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
Before step 3 you will need to reset the condition - sending the new data value from Model A into Model B.   Just changing the data in Model A does not change the value the condition is looking for in Model b - you have to expicitly resend the value using an "activate condition and send value" action.