Cannot insert /save any records to model for custom Profile in Salesforce

  • 1
  • Problem
  • Updated 2 years ago
  • In Progress
I cannot get value of field in snippet for a custom profile (the system administrator profile doesn't face this issue).


Can someone help me with this please.
Thanks in advance.
Photo of kien vu

kien vu

  • 90 Points 75 badge 2x thumb

Posted 2 years ago

  • 1
Photo of Amy Dewaal

Amy Dewaal, Official Rep

  • 8,200 Points 5k badge 2x thumb
Kien,

Try checking the permissions of the field that you're having problems with and see if your profile has permission to read it. Skuid respects all permissions set-up in your org, so if your profile isn't allowed to read that field then that might be why the snippet is returning blank.

Thanks!
Amy
Photo of kien vu

kien vu

  • 90 Points 75 badge 2x thumb
Hi Amy,

I'd set "Edit" permission for this field.
Also, the data saving worked well for standard page layout of Salesforce.
The error only occurred on Skuid page. 

Thanks!
(Edited)
Photo of Amy Dewaal

Amy Dewaal, Official Rep

  • 8,200 Points 5k badge 2x thumb
Kien,

Can you give a little more context about what your snippet does, or if it's short can you post it? Check your Chrome developer console to see if there are any errors caused in the snippet that may be causing the result to be blank. Once you have the console open look at the console tab, and then run your snippet and see if any errors come up.

Thanks!
Amy
Photo of kien vu

kien vu

  • 90 Points 75 badge 2x thumb
Hi Amy,

At the native Salesforce salesforce UI page (standard Edit page of Salesforce), I don't face this issue.
The issue only occurs on SKUID page.

Thanks!
Photo of Amy Dewaal

Amy Dewaal, Official Rep

  • 8,200 Points 5k badge 2x thumb
Kien,

Do you mind posting your snippet? I think the error might be in it.

Thanks!
Amy