Can not navigate to detail record in Community site in API v2 (Spark 12.0.6)

  • 2
  • Problem
  • Updated 6 days ago
  • In Progress
I create a new API v2 page and add an Opportunity table to this page.

I expect it will be redirected to Opportunity detail page when I click on one Opportunity link on this table. The URL is changed in the browser, but the page is not redirected.

NOTE: This issue only occurs in API V2 and Lightning Community site.


Please help to check.







Photo of Kevin

Kevin

  • 992 Points 500 badge 2x thumb

Posted 1 year ago

  • 2
Photo of Luzie Baumgart

Luzie Baumgart, Official Rep

  • 4,664 Points 4k badge 2x thumb
Hi Kevin, thank you for the screenshots. I could reproduce the issue and will report it to our dev team. I'm looking into a workaround. Did you find a workaround already?
Regards,
Luzie
Photo of Kevin

Kevin

  • 992 Points 500 badge 2x thumb
Hi Zach,

After testing in Sandbox with Spark 12.2.9, I can still reproduce this issue.
We already need API V2 in the internal and community sites as well. Could you please help to resolve it soon if possible?

Thanks.
(Edited)
Photo of Zach McElrath

Zach McElrath, Employee

  • 55,610 Points 50k badge 2x thumb
Can you grant login access to Skuid Support and provide us with steps to reproduce this?
Photo of Kevin

Kevin

  • 992 Points 500 badge 2x thumb
Hi Zach,

It's not difficult to reproduce. Only create a new V2 Skuid page and use it in Community.

Please note that this issue only appears in Lightning Community site.

Thanks.
Photo of Zach McElrath

Zach McElrath, Employee

  • 55,610 Points 50k badge 2x thumb
Hi Kevin, I have been able to reproduce the issue, and we are investigating.
Photo of Kevin

Kevin

  • 992 Points 500 badge 2x thumb
Hi Zach,

Does the issue have yet to be resolved?

Thanks.
Photo of Kevin

Kevin

  • 992 Points 500 badge 2x thumb
Hi Zach,

Could you please help me with this issue?

Thanks.
Photo of Anna Wiersema

Anna Wiersema, Official Rep

  • 11,754 Points 10k badge 2x thumb
Hi Kevin, from our conversation on the other topic (https://community.skuid.com/skuid/topics/open-a-detail-record-on-new-tab-in-community-site-doesnt-work) it sounds like you recently upgraded to 12.2.18.  

Are you still experiencing this issue after upgrade?

Photo of Kevin

Kevin

  • 992 Points 500 badge 2x thumb
Hi Anna,

This issue is still occurring.
Photo of Anna Wiersema

Anna Wiersema, Official Rep

  • 11,754 Points 10k badge 2x thumb
Hi Kevin, I did a bit more digging and found that this product defect has been fixed and is scheduled to be released in Spark Update 3. I'll let you know when this release is available for testing.
Photo of Kevin

Kevin

  • 992 Points 500 badge 2x thumb
Hi Anna,

I hope to get the Spark Update 3 soon.

Thank you so much for your help.
Photo of Anna Wiersema

Anna Wiersema, Official Rep

  • 11,754 Points 10k badge 2x thumb
You're welcome.