Campaign Member inline create remoting exception: Invalid Id

  • 1
  • Problem
  • Updated 1 year ago
  • In Progress
I receive a remoting exception when saving a new record in a table for Campaign Members. The only filter condition on the Campaign Member model is the Lead Id which is pulled from the url parameter. Updates work fine it is only new Campaign Records that produce this error. 

This is occurring in our sandbox environment that is currently using Superbank - Patch 9 Version 6.8.20.

In order to take out any variables, I created a brand new page from scratch with only Lead and Campaign Member models. Same error occurred. See screenshot for reference.

Photo of John De Santiago

John De Santiago

  • 736 Points 500 badge 2x thumb

Posted 3 years ago

  • 1
Photo of Ben Hubbard

Ben Hubbard, Employee

  • 12,490 Points 10k badge 2x thumb
That's strange. Is there a campaign named "f this campaign"? How does it relate to the Campaign Member being added?
Photo of John De Santiago

John De Santiago

  • 736 Points 500 badge 2x thumb
I am not even sure what that is the campaign is what you see in the editable text box. When I look at the skuid model it will have the temporary Id numbers ("2" in this case) it also has a reference to the lead and the campaign and both ids in the model look correct. 
Photo of John De Santiago

John De Santiago

  • 736 Points 500 badge 2x thumb
Here is a screenshot of the error with the data model expanded to show what that new record looks like. This used to work fine. We recently updated to the version we are on now and we believe that is when the problem started but we can't be sure. 

Photo of John De Santiago

John De Santiago

  • 736 Points 500 badge 2x thumb
Also, I just double checked and I don't have any campaign in the system with the words "f this campaign"
Photo of Ben Hubbard

Ben Hubbard, Employee

  • 12,490 Points 10k badge 2x thumb
That's absolutely bizarre. I'm building a similar page right now in that version of Superbank. I'll let you know how it goes. Do you have any rogue triggers or validation rules in there? Do you have any leads with the name "f this campaign"?
Photo of John De Santiago

John De Santiago

  • 736 Points 500 badge 2x thumb
No leads. Did a SOSL search as well for "campaign" and combed through it and didn't find this arrangement of text. 
(Edited)
Photo of Ben Hubbard

Ben Hubbard, Employee

  • 12,490 Points 10k badge 2x thumb
Well, I was not expecting to say this, but I reproduced this error in a brand new org. I'll keep investigating.
Photo of Ben Hubbard

Ben Hubbard, Employee

  • 12,490 Points 10k badge 2x thumb
However, so far, I've only been able to get this error when I try to add a duplicate campaign member record. One where a campaignmember already exists on that combination of lead and campaign.
Photo of John De Santiago

John De Santiago

  • 736 Points 500 badge 2x thumb
You know that might be the case with us as well. We found it testing a feature out in our sandbox and we were reusing a lot of the same campaign names. Let me try to confirm.
Photo of John De Santiago

John De Santiago

  • 736 Points 500 badge 2x thumb
I confirmed it only occurs if they already have an existing campaign member record to that campaign. I think I can work around that now that we know that is what it is. Thanks.
Photo of Velvel Marasow

Velvel Marasow

  • 172 Points 100 badge 2x thumb
Has this ever been fixed?