buttons out of alignment in lightning

  • 1
  • Problem
  • Updated 6 months ago
  • Acknowledged
Photo of Conlan O'Rourke

Conlan O'Rourke

  • 3,280 Points 3k badge 2x thumb

Posted 7 months ago

  • 1
Photo of Stephen Sells

Stephen Sells, Official Rep

  • 16,856 Points 10k badge 2x thumb
Can you provide any more specifics? 
What version of Skuid are you running on?
Are your themes out of date or have they been updated?
Photo of Conlan O'Rourke

Conlan O'Rourke

  • 3,280 Points 3k badge 2x thumb
Just installed 11.1.10 today, I haven't touched the themes at all. No custom CSS on my page yet
Photo of Conlan O'Rourke

Conlan O'Rourke

  • 3,280 Points 3k badge 2x thumb
Seems to only be affecting the last button in the button set.

Photo of Conlan O'Rourke

Conlan O'Rourke

  • 3,280 Points 3k badge 2x thumb
Looks like the last button's div container is missing the following CSS:

margin-bottom: 1.5rem;

I added the CSS in-line to that specific button's unique id as a workaround for now.
Photo of Stephen Sells

Stephen Sells, Official Rep

  • 16,856 Points 10k badge 2x thumb
After upgrading, you'll want to press this button:


Let me know if this does the trick
Photo of Conlan O'Rourke

Conlan O'Rourke

  • 3,280 Points 3k badge 2x thumb
No, this didn't do it. I created this video which shows some other issues I am seeing, mostly with tables.

http://recordit.co/9cMftA8LQc
Photo of Conlan O'Rourke

Conlan O'Rourke

  • 3,280 Points 3k badge 2x thumb
Stephen, have you had a chance to look into these issues? 

We're currently running 11.1.11 in a Lightning community when seeing these issues


...but not seeing them when previewing the page outside of the Lightning community
Photo of Stephen Sells

Stephen Sells, Official Rep

  • 16,856 Points 10k badge 2x thumb
It appears there's an issue in how we are aligning table headers in certain themes in Lightning Communities. I am logging this as a known issue in our tracking system so I will archive this ticket here. There is not a target date for getting this issue addressed yet but our devs are aware of it.
Photo of Conlan O'Rourke

Conlan O'Rourke

  • 3,280 Points 3k badge 2x thumb
Thanks Stephen. What would be your recommendation in the meantime? All the themes that I have tried are producing the same issue. What themes are currently working as expected in Lightning?

Alternatively, should I be planning to rollout the community on Classic Visualforce tabs?
Photo of Stephen Sells

Stephen Sells, Official Rep

  • 16,856 Points 10k badge 2x thumb
In the meantime I would recommend trying a few other themes. I know it is broken for Modern, classic, and a few others, but you might get lucky with one in your org. Then you could base a theme around one that works using the theme builder.

That would be worth an attempt
Photo of Conlan O'Rourke

Conlan O'Rourke

  • 3,280 Points 3k badge 2x thumb
I have tried every theme, and all appear to be having this issue. I'll plan to move forward with a visualforce community for the time being. Please do escalate this with the dev team as this is causing Skuid on Lightning to be a non-viable product for our use case at this time. Thanks Stephen.
Photo of Louis Skelton

Louis Skelton

  • 4,878 Points 4k badge 2x thumb
I'm having this issue too.
Photo of Conlan O'Rourke

Conlan O'Rourke

  • 3,280 Points 3k badge 2x thumb
Just an update after having upgraded to 11.1.14.

It appears that the CSS is displaying worse in Lightning Communities. I've tried with numerous themes, and seeing the same result in all of them.



Page in Lightning Communities




Page preview (outside Lightning Communities)
Photo of Louis Skelton

Louis Skelton

  • 4,878 Points 4k badge 2x thumb
Hey Conlan - where do you have your CSS out of interest? Is it in the theme? Have you tried putting it in the Skuid page directly or in a Lightning Component instead? My approach with Lightning Communities has been to have all the css styles in a staticresource which is referenced either in the Lightning Component or as a css item in the Skuid page.
Photo of Conlan O'Rourke

Conlan O'Rourke

  • 3,280 Points 3k badge 2x thumb
Hey Louis, it's pretty much all coming from the theme. How do you reference a static resource from a Lightning Component?