Buttons have different format on page with Tab set

  • 1
  • Problem
  • Updated 1 year ago
  • Not a Problem
Hi,

My buttons in a button set have a different format on the same page if they are part of a tab set or not. I have a custom theme and use Skuid 10.0.0.2

It somehow seems that my custom theme only applies to button sets that are part of the tab set . Please see screenshots below of what I mean, I have a Table and a Button set above and below the tab set. 
The theming below the tab is the correct one.


Screenshot from Salesforce
 


Screenshot from the editor




Below is a screenshow from the Theme editor where it shows that the buttons under the tab set are the 'correct' theme.




I can override it with CSS (this seems to work: .ui-button, .ui-widget-content .ui-button.ui-state-default {background:#fa0046;}  )

However it is strange that it should happen like this, that buttons in the Tab set somehow seem to inherit a different style. See the screenshot from the Developer Console where for some reason the background is not what it should be (the buttons under the tab don't have these style elements crossed out).




Any suggestions as to how and why?

Thanks
Photo of thomas haelsig

thomas haelsig

  • 290 Points 250 badge 2x thumb

Posted 1 year ago

  • 1
Photo of Mark DeSimone

Mark DeSimone, Official Rep

  • 11,050 Points 10k badge 2x thumb
Hi Thomas. Have you updated your out of date themes (via the themes list page) since updating your Skuid version?
Photo of thomas haelsig

thomas haelsig

  • 290 Points 250 badge 2x thumb
Yes, I have had already previously updated the out of date themes upon updating the Skuid version
Photo of Mark DeSimone

Mark DeSimone, Official Rep

  • 11,050 Points 10k badge 2x thumb
Does your theme have any custom CSS rules written, or were all the changes made with the theme editor's interface?
Photo of thomas haelsig

thomas haelsig

  • 290 Points 250 badge 2x thumb
Hi Mark,
Just a very simple CSS to hide the table footer, but nothing else really.

The thing is also that it the buttons are different in the other themes as well, not only the custom one (e.g. if I use the Lightning theme, the buttons in the tab set are different that those not in the tab set).
Photo of thomas haelsig

thomas haelsig

  • 290 Points 250 badge 2x thumb
Hi Mark,

I found the error, there was one css in the parent page that added a theme. I completely missed it and thought I had deactivated it.
Thanks for looking into it, should have done that error checking by myself!

Thomas
Photo of Mark DeSimone

Mark DeSimone, Official Rep

  • 11,050 Points 10k badge 2x thumb
Glad to hear it, and thanks for following up with that resolution.