Brooklyn Issue -- Page Redirect Occurs On Page Load

  • 1
  • Problem
  • Updated 2 years ago
  • Solved
  • (Edited)

A page that has been working in prior releases has all of a sudden stopped working when upgrading to brooklyn.  The page loads then immediatly redirects to "salesforce.com/1". Which implies to me that it is trying to redirect to the record created before the executing action occurs.  In a full working page, we redirect to a record via javascript due to other logic within the page. It occurs in both Winter 17 and Spring 17 enviroments 


Has anyone else seen this issue?  

Photo of rensley

rensley

  • 316 Points 250 badge 2x thumb

Posted 2 years ago

  • 1
Photo of Mark DeSimone

Mark DeSimone, Official Rep

  • 11,040 Points 10k badge 2x thumb
Hi rensley,

It sounds like the order of actions in your script might have something to do with the behavior you're seeing; as though the redirect is pointing to a temporary ID#, or something like that. Can you provide any more detail about what the script is doing? Is the user supposed to be brought to a record detail page for a new record that was just created on the previous page? 
(Edited)
Photo of rensley

rensley

  • 316 Points 250 badge 2x thumb
The page itself is a wizard. The script is executed via button click on the last page of the wizard itself. Along with redirecting the page, it calls a apex remote method. This has been running in our produciton org since August without issue. 
Photo of Mark DeSimone

Mark DeSimone, Official Rep

  • 11,040 Points 10k badge 2x thumb
I see. Does the record end up getting created, and it's the redirect that's failing, or is there a problem with the record being saved?
Photo of rensley

rensley

  • 316 Points 250 badge 2x thumb
It occurs as soon as the user lands on the page. The page itself is for record creation.
Photo of rensley

rensley

  • 316 Points 250 badge 2x thumb
It looks like this question can be marked Resolved with the most recent Skuid release.