Brooklyn issue (10.0.4) - action column has a width of 1px

  • 1
  • Problem
  • Updated 1 year ago
  • Solved
Table component:
We have > 1 icons in the action column. It is now displayed as 1px
table.nx-skootable-data tr th.actioncolumn, table.nx-skootable-data tr th.checkcolumn width:1px

Is it expected that we should need to override in our theme?
Photo of jili@heidrick.com

jili@heidrick.com

  • 2,032 Points 2k badge 2x thumb

Posted 1 year ago

  • 1
Photo of Skuidward Tentacles (Raymond)

Skuidward Tentacles (Raymond), Champion

  • 17,224 Points 10k badge 2x thumb
On the theme composer, did you click the "update out of date themes" button. That usually fixes issues like this following upgrade
Photo of jili@heidrick.com

jili@heidrick.com

  • 2,032 Points 2k badge 2x thumb
Thanks, that fixed this issue. Now other styles look off.
1. The text fields in edit mode now have a light yellow background color
2.  Background in the drawer show a mix of the light yellow, the salesforce blue for open spaces and the white background from the field editor.
Photo of Skuidward Tentacles (Raymond)

Skuidward Tentacles (Raymond), Champion

  • 17,224 Points 10k badge 2x thumb
light yellow in edit mode may be the theme. The new theme editor has more options and maybe the upgrade added a setting that wasn't there before. Check to see if the theme has a setting for light yellow background in text field edit mode. Same for the drawer. Other than that, I don't have a lot of ideas other than that you can probably correct them by adding your own CSS
Photo of jili@heidrick.com

jili@heidrick.com

  • 2,032 Points 2k badge 2x thumb
OMG. I tried unchecking background for Field Editor. That fixed the background color mix issue. But it completed changed the look and feel of the page from Rockaway. Margins, border styles for custom template all look different and off. I now turned the background back on for Field Editor, the page has not reverted to the old style...