banzai popup image preview not working

  • 1
  • Problem
  • Updated 3 years ago
  • Solved
We just uploaded an org to Banzai and have a big problem. We have a lot of pages where we use a table that displays a list of records and a popup row action that shows more data plus images using the file upload component. However all images have disappeared from the pages everywhere this pattern s used. Testing this with very simple pages gives the same result. Whenever the File Upload component is used in a popup the preview is not working. Switching the File Upload component to "Display as File Name" and everything works ok. Displaying the same image using a template component works so it does not seem to be an issue of not loading the correct data in the context. Rebuilding every page where this is used to a combination with template for preview would take most of the night but unless there is a quick solution I will have to either do this or downgrade to an earlier version before users come back tomorrow. So all suggestions on how to fix this is very welcome
Photo of Peter Baeza

Peter Baeza

  • 2,868 Points 2k badge 2x thumb

Posted 3 years ago

  • 1
Photo of Zach McElrath

Zach McElrath, Employee

  • 49,056 Points 20k badge 2x thumb
Peter, can you Grant Login Access to Skuid Support and send us the Org Id and a url to a page in the org where we can view this occurring? We'll take a look at it. We're planning to release a new version of Skuid Banzai today so there's a good chance we can get this resolved for you without the need to downgrade or something else awful.
Photo of Peter Baeza

Peter Baeza

  • 2,868 Points 2k badge 2x thumb
Zach, I'll email all details to you in a moment. The org is in swedish so I'll make sure to provide you with direct links to a test page for this.
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
Peter we have found the problem and fixed it in our Dev org.  It will be included in the next package release - which we hope will be today. 
Photo of Peter Baeza

Peter Baeza

  • 2,868 Points 2k badge 2x thumb
Perfect thanks, looks like I might get some sleep tonight then..... Hope I'll see you at Dreamforce.
Photo of Zach McElrath

Zach McElrath, Employee

  • 49,056 Points 20k badge 2x thumb
Peter, we have installed a new version of Banzai in your org (7.8) and this appears to be resolved.
Photo of Peter Baeza

Peter Baeza

  • 2,868 Points 2k badge 2x thumb
thanks Zach, I can confirm that it works. I have however found what appears to be another bug in Banzai that completely breaks some pages. I'm logging it as another problem.