Attempting to Upgrade and Failing

  • 1
  • Problem
  • Updated 9 months ago
  • Solved
Hey, I am trying to use Skuid for SF and getting this error message when attempting to upgrade. Any suggestions?

This app can't be upgraded. There are problems that prevent this package from being installed. Dependent class is invalid and needs recompilation: Class skuid.Utils : Method does not exist or incorrect signature: void publish(List) from the type EventBus
Photo of Trent Morrison

Trent Morrison

  • 102 Points 100 badge 2x thumb
  • Angry and Anoyed

Posted 12 months ago

  • 1
Photo of Stephen Sells

Stephen Sells, Official Rep

  • 16,856 Points 10k badge 2x thumb
Official Response
Hello Skuid Community ~

Thank you for your thoughtful suggestion! Skuid listened to your concern and has implemented your idea in the new Skuid Brooklyn (10.0.15) and Skuid Version Millau (11.0.5) release which is now available on the Skuid Releases page.

As a reminder, Salesforce does NOT allow reverting back to prior versions of managed packages. Skuid always recommends installing new versions in a non-business critical sandbox environment to test all mission critical functionality before installing into a production environment. We also recommend that you update out of date themes when you upgrade.