Archived Tasks not redirecting to Standard Salesforce Layout

  • 1
  • Problem
  • Updated 4 years ago
  • Solved
We are using page assignments to redirect to Skuid pages for specific record types. With Tasks, we have only 1 record type assigned for View. All others Tasks redirect to the standard Salesforce page layout.

When coming across an archived Task for a record type that isn't listed in page assignments, the page is showing "Data Not Available", as in this issue: https://community.skuidify.com/skuid/topics/page_assignments_not_working_for_archived_tasks

The above issue seems to relate to using a Skuid page for an archived Task, where our issue is when we wish to use the standard layout for the archived Task.

URL when a view link is clicked for an archived Task with no page assignment:
https://c.eu1.visual.force.com/apex/TaskView?id=00TD000001Tbm3n&sfdc.override=1

URL when a view link is clicked for an active Task with no page assignment:
https://eu1.salesforce.com/00TD000001OMRf1?nooverride=1&sfdc.override=1
Photo of Ross James

Ross James

  • 490 Points 250 badge 2x thumb

Posted 4 years ago

  • 1
Photo of Zach McElrath

Zach McElrath, Employee

  • 49,056 Points 20k badge 2x thumb
Ross, can you please post the body of your TaskView Visualforce Page?

I was able to get this to work by removing the titleattribute from my Visualforce Page. 

It seems like Salesforce throws a fit if you try to show any fields from an archived Task within the title of a Visualforce Page using the Task standard controller --- if you just remove the title, or change the title to be something that does not contain any Task fields, it seems to work.

Here's my working VF override page:

<apex:page standardController="Task" tabStyle="Task"
        extensions="skuid.Redirects" action="{!IF(canUseSkuid,'',redirect)}"
        sidebar="false" readOnly="true" docType="html-5.0">
   <skuid:page objecttype="Task" actiontype="View"/>
</apex:page>

Also, I'm assuming you've already got this working, but make sure that the Task Model on your Skuid Page has the "Query Archived / Deleted Rows" rows property checked in the Advanced properties panel for the Model.
Photo of Ross James

Ross James

  • 490 Points 250 badge 2x thumb
Zach, this fixed it. Thanks for the swift response.