App Default Landing Tab of Visualforce Tab of Skuid Page Not Working

  • 1
  • Problem
  • Updated 3 years ago
Photo of mB Pat Vachon

mB Pat Vachon, Champion

  • 42,674 Points 20k badge 2x thumb

Posted 3 years ago

  • 1
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
Your setup looks to be correct.  (As far as I can tell on Youtube).  I've implemented that strategy with lots of customers and never heard a complaint.  It almost looks like you have a Salesforce Bug.  Not to point fingers or anything... 
(Edited)
Photo of mB Pat Vachon

mB Pat Vachon, Champion

  • 42,674 Points 20k badge 2x thumb
Can you take a look?
Photo of J.

J., Official Rep

  • 7,470 Points 5k badge 2x thumb
I've seen something like this before, and I think we concluded that it was indeed a Salesforce issue. It only seemed to happen with existing Users though. If you create a brand new User, does it work as expected? My memory is a little fuzzy, but I think that key is in the wording: Default Landing Tab. Users who logged in before that tab was added and set to default are going to the Home page because that's what Salesforce has stored for that User. It's not clearing the default for existing Users when you change it. That's all totally speculation on my part though. I haven't found anything official on the subject.

You could try removing the existing User's access from the App, then giving it back, or maybe even setting up a new App and setting the Default page during the set up, but I don't know if either of those actually work. If all this lines up with what you are seeing, you might try turning a Case with Salesforce too. 
Photo of mB Pat Vachon

mB Pat Vachon, Champion

  • 42,674 Points 20k badge 2x thumb
Well. It's odd. Doesn't seem to matter if it's a new user or not. Seems to be based on whether or not you've ever logged into the app. Not entirely convinced though. I seem to remember other behaviours.
Photo of Craig Rosenbaum

Craig Rosenbaum

  • 4,776 Points 4k badge 2x thumb
We had a similar thing happen right after upgrading to Banzai. A user who doesn't even have page editor rights and in his words "doesn't know what a Skuid is" logged in and was brought to the page editor for a specific Skuid page.  It was very strange and we were not able to replicate it. I understand the lack of details and specifics are not particularly helpful, but something to be aware of. I believe this was his first time logging in after we updated to Banzai. He was also the only one to experience the issue and it only happened once.