Allow Ordering checkbox isn't there

  • 1
  • Question
  • Updated 3 years ago
  • Answered
I'm new to Skuid, so I'm hoping I'm just missing something.  I have built a table (Basic model) and want users to be able to sort by any of the columns in the table.  I set the default sort (Product_Number__c ASC) and this works.  However, I can't find a setting to allow ordering.  Screenshots in other posts show a checkbox under field properties called "Allow Ordering".  I don't have that checkbox.  What am I missing?
Photo of Chris Inouye

Chris Inouye

  • 142 Points 100 badge 2x thumb

Posted 3 years ago

  • 1
Photo of Jack Sanford

Jack Sanford, Champion

  • 8,322 Points 5k badge 2x thumb
Hi Chris, be sure you are clicking the column heading in the actual table on your layout for field properties, and not clicking on the field properties in the models. Can you post a screenshot of what you see in the field properties window?

FYI you don't need to type in ASC it will sort by Ascending by default, just need DESC if you want it that way. 
Photo of Karen Waldschmitt

Karen Waldschmitt, Official Rep

  • 8,220 Points 5k badge 2x thumb
Chris~

Here is a screenshot to demonstrate what Jack replied.

When you click on the field in the table, you will see the field properties above. Click the box that shows "Allow Ordering."



Hope that helps!
Karen
Photo of Chris Inouye

Chris Inouye

  • 142 Points 100 badge 2x thumb
Jack, thanks for the quick response.  I'm clicking into the table and onto the column name as you are saying.  Thanks for the tip on the default sort order.

Photo of Jack Sanford

Jack Sanford, Champion

  • 8,322 Points 5k badge 2x thumb
Can you scroll down in that Field Properties window?
Photo of Chris Inouye

Chris Inouye

  • 142 Points 100 badge 2x thumb
No, I cannot. :-(
Photo of Chris Inouye

Chris Inouye

  • 142 Points 100 badge 2x thumb
Other columns allow me to scroll because the "Column Summaries" button pushes down the Read-only and Required options.

Here's a little more information that might help.  
  • On the Model, the Fields are almost all set to "Override field metadata" so that I can toggle to "Read Only".  
  • "Load Model data on page load" is checked.  
  • "Process Model client-side" is currently checked, though I tried it with this unchecked.
Photo of Jack Sanford

Jack Sanford, Champion

  • 8,322 Points 5k badge 2x thumb
You don't need to use Override field metadata to make it Read Only, you can do that at the field instance level in the table. Once you turn that off you should be able to Allow Ordering in the field properties (and also set Read Only as needed).
(Edited)
Photo of Chris Inouye

Chris Inouye

  • 142 Points 100 badge 2x thumb
Yes!!  That was it!  Thanks for your help.