All of a sudden - none of my page includes are loading in lightning.

  • 4
  • Problem
  • Updated 6 months ago
  • Solved
Came into work today and for some reason none of the page includes are working in lightning. They were fine yesterday.... anyone else having this issue? Am i just going insane..?
Photo of June Duan

June Duan

  • 192 Points 100 badge 2x thumb

Posted 2 years ago

  • 4
Photo of Don Souza

Don Souza, Employee

  • 1,160 Points 1k badge 2x thumb
Are you using a Skuid page as a custom Lightning component?
Photo of Erik Wahlberg

Erik Wahlberg

  • 2,156 Points 2k badge 2x thumb
Same issue over here but this is unique in that Page Include works on some computers/browsers and not others. Page includes used to work in my sandbox while I was able to confirm it not working for other computers, but this morning I was too switched over to being unable to load.

Important to note, the Query String is being brought over but it gets stuck on loading.


Photo of Amy Dewaal

Amy Dewaal, Official Rep

  • 8,200 Points 5k badge 2x thumb
June and Erik,
Has anything in your org changed since they worked? For example, a upgrade to Skuid or an upgrade to Salesforce Winter '18?
Photo of Erik Wahlberg

Erik Wahlberg

  • 2,156 Points 2k badge 2x thumb
Nothing changed in the org to my knowledge, this is in our Sandbox so it was already in Winter '18 when we started development. I noticed some interesting behavior which is that it works in page preview but not from within the page. I've attached a short video of this behavior

(Edited)
Photo of Amy Dewaal

Amy Dewaal, Official Rep

  • 8,200 Points 5k badge 2x thumb
You mentioned it works on some computers / browsers but not others - what combinations does it work on, and which does it not work on? What version of Skuid are you on?
Photo of Erik Wahlberg

Erik Wahlberg

  • 2,156 Points 2k badge 2x thumb
Well my computer was the one it was working on and then it stopped, but during the time it was working on my computer I confirmed it wasn't on a few co-workers computers. Both were through Chrome and both browsers were fully updated.

We're on 10.0.7 but I did just now see a new release on the 4th for 10.0.9. I'm going to update our sandbox to that and see if that fixes this issue. 
Photo of Erik Wahlberg

Erik Wahlberg

  • 2,156 Points 2k badge 2x thumb
Just updated, restarted computer, and tested the behavior and it's still there.

In the page preview the page include inside the drawer loads fine. In the actual page in deployment, it's stuck perpetually loading even after it looks like the querrystring is working fine (fields appearing are correct). 

Attaching screenshots of the console log from both the Page Preview(Working) and from within page(Not Working)

Page Preview (Working)


Within Page (Not Working
(Edited)
Photo of Amy Dewaal

Amy Dewaal, Official Rep

  • 8,200 Points 5k badge 2x thumb
June and Erik,

I have been able to reproduce this issue and have notified our devs about it. We'll let you know when this is fixed in a future release.

Thanks!
Photo of Rich Slack

Rich Slack

  • 4,134 Points 4k badge 2x thumb
Any update on this?  If it is the same issue I am having it looks like the page includes don't load because Salesforce changed the URL.

It used to be /apex/ClientDetail?id=001G000001F1iL5IAJ001G000001ejscf&sfdc.override=1
Now it is /lightning/r/Account/001G000001F1iL5IAJ/view

I am guessing Skuid is looking for the id= and not finding it?  The reason it loads off of preview is because we are manually feeding the parameter in.  Or is mine a separate question?
Photo of Rich Slack

Rich Slack

  • 4,134 Points 4k badge 2x thumb
Hi Amy, any updates on this?  Thank you!
Photo of Chandra V

Chandra V, Champion

  • 6,966 Points 5k badge 2x thumb
We are converting to lightning, and our page includes work.... but we pull ID to the query string from the model NOT the url parameter.  I believe a fix is coming, but I was told best practice is to pull the id off a model {{$Model.MyModel.data.0.Id}} and not $Param.
Photo of Rich Slack

Rich Slack

  • 4,134 Points 4k badge 2x thumb
Thanks! I will give it a shot Chandra.  As always I appreciate your help!
Photo of Rich Slack

Rich Slack

  • 4,134 Points 4k badge 2x thumb
That did the trick.  Thank you!
Photo of Mark DeSimone

Mark DeSimone, Official Rep

  • 11,050 Points 10k badge 2x thumb
Hi Rich. Chandra's suggestion is a really solid one. This limitation is of course still on Skuid's radar, but by bringing the necessary params into a model so you can use merge variables instead of $Params, I think you'll run into fewer issues as you do more things in Lightning, which is intended to be a one-page app.