all Non Admin Users getting error when clicking on reference fields to open page

  • 2
  • Problem
  • Updated 8 months ago
  • Solved
As of this morning, all users (except myself Admin) are getting error messages when trying to open most pages.  The error msg is attached w screenshot.   I updgraded Miliau 11.1.4 from 11.1.1 yesterday.  Any help would be appreciated.  Thanks

Photo of Ann Kukich

Ann Kukich

  • 1,316 Points 1k badge 2x thumb

Posted 8 months ago

  • 2
Photo of Stephen Sells

Stephen Sells, Official Rep

  • 16,856 Points 10k badge 2x thumb
Do your non admin users have  "Skuid Page Viewer" permission?
Photo of Stephen Sells

Stephen Sells, Official Rep

  • 16,856 Points 10k badge 2x thumb
Our developers are aware of this issue. We'll notify you here when the fix is put out in an update of Skuid.
Photo of Luzie Baumgart

Luzie Baumgart, Official Rep

  • 1,310 Points 1k badge 2x thumb
Until the fix is put out in an update, you could check if those pages contain a relationship field that includes a field which is inaccessible to the current user. If yes and if you can allow this user access to that parent field, it should help as a workaround.
Photo of Ann Kukich

Ann Kukich

  • 1,316 Points 1k badge 2x thumb
In order to get the users all working, I made them temporary Admin Profiles.   And, like you suggested, I have been going through ols and fls and changing persmissions.   We use the User model alot, so that has been a challenge.   Thanks for the tip Luzie
Photo of Luzie Baumgart

Luzie Baumgart, Official Rep

  • 1,310 Points 1k badge 2x thumb
Happy to hear that you could get it working. Thank you for the quick feedback!
Photo of Luzie Baumgart

Luzie Baumgart, Official Rep

  • 1,310 Points 1k badge 2x thumb
The new version has been released:
https://www.skuid.com/releases/salesforce/
Photo of Ann Kukich

Ann Kukich

  • 1,316 Points 1k badge 2x thumb
Thank you!!