Account Page Won't Load in Lightning Experience after Millau 11.2.18

  • 1
  • Problem
  • Updated 1 month ago
  • (Edited)
I just upgraded to the lastest Millau patch of 11.2.18.  Everything appears to be working fine in Classic.  However, I have 4 console users who are on Lightning so they can see better case information.  When they click on an Account page (totally skinned with Skuid, including page includes etc.) they are getting an error:
"Unfortunately, there was a problem. Please try again. If the problem continues, get in touch with your administrator with the error ID shown here and any other related details. Error ID: 1873906661-77759 (-1659005954)Unfortunately, there was a problem. Please try again. If the problem continues, get in touch with your administrator with the error ID shown here and any other related details."

The page works fine in Classic so I am assuming it is how the page is set up or the page assignments not playing well with lightning. I saw a string that discussed a similar issue a couple of years ago.  But they were told to submit a ticket and no resolution was posted to the community.  Is there a workaround when only some of your team is on lightning? I know they can just switch back to classic for now.  But do we know why this is happening and is there something I can do to the pages to make them work in both classic and lightning?

Thanks
Rich
Photo of Rich Slack

Rich Slack

  • 4,248 Points 4k badge 2x thumb

Posted 2 months ago

  • 1
Photo of Rich Slack

Rich Slack

  • 4,248 Points 4k badge 2x thumb
I did some more testing and most Skuid pages are loading fine in Lightning. The error only occurs when an Account detail tab is opened.  I tried removing page includes one by one. I tried removing models one by one.  I finally deleted the whole page and just had a very simple page and am still getting the error.  I then switched the page assignment for my profile to be (Use Standard Layouts) and I am still getting the error.  


Photo of Chandra V

Chandra V, Champion

  • 7,400 Points 5k badge 2x thumb
What is the syntax of the page include query parameters you are passing?  When we switched to lightning, our page includes had to have the syntax tweaked to work.  Ours was we were using $Param to pass the parameter.  After switching it to a model field merge ( {{id=$Model.Account.data.0.Id}} ) it worked fine.
Photo of Rich Slack

Rich Slack

  • 4,248 Points 4k badge 2x thumb
I submitted a Salesforce ticket and they of course said it was a Skuid issue.  They had me check the Enable VisualForce check box in the ClientDetail visual force page.  It didn't help.

The tricky part is that other Skuid pages are working fine.  In fact, I am using page assignments so I can make the page redirect to whatever page I want it to.  So I switched it to a page that is loading fine in Lightning and I am still getting the same error.  Whenever I click to open account detail page whether via global search or via a link I get the error if it is an account. The error only occurs on Account pages. 
Photo of Rich Slack

Rich Slack

  • 4,248 Points 4k badge 2x thumb
So the solution to this if anyone runs into this in their switch to lightning is:
1. Setup
2. Customize
3. Accounts
4. Buttons, Links, and Actions
5. Edit "View"
6. Switch Lightning Experience Override to be "Use the Salesforce Classic Override" or I suppose you could create a lightning component.

Simple fix.
(Edited)