"Row in Model updated" only works the first time the model is loaded

  • 1
  • Question
  • Updated 2 years ago
The action "Row in Model updated" is only working the first time the model is loaded. If you change the page or select a different item from the filters, it does not trigger the "Row in Model updated" action.

What can I try here? Thanks in advance!
Photo of Kyla Longe

Kyla Longe

  • 170 Points 100 badge 2x thumb

Posted 2 years ago

  • 1
Photo of Zach McElrath

Zach McElrath, Employee

  • 49,004 Points 20k badge 2x thumb
Kyla, I think there's some confusion here with what the "Row in Model updated" action does. You're looking for the "Model requeried" event.

The "Row in Model updated" event is only published when a user makes a change to a row, e.g. changing an Account's Name from "Acme" to "Blah". The "Model requeried" event is published when Models are first loaded, when you change filters, when you enter search text, etc --- any time that the Model is queried.
Photo of Will.I.Yam

Will.I.Yam

  • 216 Points 100 badge 2x thumb
Zach hit the nail on the head. Per our conversation yesterday, the actions you're taking are on the model (a Model action) instead of the row in the table (a Row action).

That would explain a few things! I think I was able to steer you in the right direction. If not, go ahead and reach out and we can try a few other things.
Photo of Kyla Longe

Kyla Longe

  • 170 Points 100 badge 2x thumb
Yeah, I'm in a better place now. But man, I gotta tell you, the wrong choice of a Model Row Action and the right choice of a Table Row Action for what we actually wanted to do is a nuance that *REALLY* tripped me up.

I'll get there though, if you're patient with me! Thanks again Will... & Zach too.