"Global Action" Mark Row(s) for Deletion different behavior

  • 2
  • Problem
  • Updated 2 years ago
  • In Progress
  • (Edited)
My pages are exhibiting different behavior but I don't know why.  I have two different pages.  On one page I have a table and a "GLOBAL ACTION" that "Marks Row(s) for deletion" and then saves the model.  

On one page ALL rows are being marked for deletion.  On the other page with the same setup only the FIRST row is marked for deletion.  I selected the Global Action so that it would mark all rows.  

What would cause one table to mark the first row an the other table to mark all rows if they are both Global Actions?

Thanks!
Photo of Rich Slack

Rich Slack

  • 4,134 Points 4k badge 2x thumb

Posted 2 years ago

  • 2
Photo of mB Pat Vachon

mB Pat Vachon, Champion

  • 42,714 Points 20k badge 2x thumb
Me as well. I've got a page that behaves the same. Out of curiosity, does the page that deletes only one have a Page Title with the model in question set to it?
Photo of Rich Slack

Rich Slack

  • 4,134 Points 4k badge 2x thumb
Yes!  You got me excited for a second.  The one that is deleting ALL has a page title but I had it pointed to a different model.  The one that is deleting just 1 row has a page title with the same model.  (I thought maybe that was the secret) So I pointed the Title to a different model.  Same behavior, still only deletes one.  So I deleted the page Title all together (in the pop up).  Same behavior still only deletes 1 row.  

I would play with the one that is working but I don't want to mess up a good thing :)
(Edited)
Photo of Rich Slack

Rich Slack

  • 4,134 Points 4k badge 2x thumb
I am on to it!!  So if the button, that calls the pop up, is on a page title that has the same model that is when the 1 row error occurs.  

I changed the Page Title, where the pop-up button was located, to a different model and the Delete All immediately started working. 
(Edited)